Need help? Check out our Support site, then


Full text won't show on front page, only summary

  1. Hello, on my blog only the summary of my posts show and not the full text and I can't seem to fix it. I've tried changing themes and so on but the problem stays the same. The setting on the reading option is to show full text not summary, but still only the summary shows.

    Any help is appreciated.

    Sarahgetscritical.wordpress.com

  2. I have the opposite issue! Surely someone can help us.

  3. @omgitsarah
    I see you are using Clean Home now and are displaying a full single post on the front page of the blog. Most older themes are designed to display full posts on the front page. Some newer themes are designed to display only excerpts of posts on the front page ie. magazine style.

    Whether or not full posts are displayed on Categories Pages and Archives pages is theme dependent ie. it's coded into the template and we cannot edit templates or themes. http://en.support.wordpress.com/themes/editing-themes/

    In the majority of themes, posts on category or other archive pages show up just as they do on the main posts page in the blog and the number displayed is also the same. (See this page > Settings > Reading and note how many posts you choose there sets it for all). But in some themes only the beginnings of posts are shown, and in a few themes you only get titles or thumbnails. See here for a theme list of themes that may display the way you want > Category/archive pages: full posts or not http://wpbtips.wordpress.com/2009/03/25/full-posts-in-archive-pages/

    Note 1: We can insert "the more tag" into posts on any theme to create front page excerpts. http://en.support.wordpress.com/splitting-content/more-tag/

    Note 2: In magazine styled themes only excerpts display on the front page of the blog but some have an active excerpt box below the post editor, so you can control the length of the excerpt displayed. This is the workaround you can use to override excerpt display on the front page and display a whole post instead.

    When creating a post or page on your WordPress.com blog, you have two editing modes available to you: Visual Editor and Text Editor (HTML).

    You compose your whole post first in the Visual editor and before you publish it you switch to the HTML (Text) editor, copy all the code you find there, paste it into the Excerpt box, and publish the post. http://en.support.wordpress.com/splitting-content/excerpts/#creating-excerpts

    This will have to be done on every post.

  4. The setting on the reading option is to show full text not summary, but still only the summary shows.

    That setting is for the RSS Feed for your posts only. Changing it from "full text" to "summary" and visa versa has not effect on the posts on the front page of the blog.

    Syndication feeds show the most recent items
    For each article in a feed, show
    Full text
    Summary

    See: Note 1: We can insert "the more tag" into posts on any theme to create front page excerpts. http://en.support.wordpress.com/splitting-content/more-tag/

  5. Thank you! I just found that 'More Tag'. I was only wondering what that was for last week!

    Thanks again.

  6. You're welcome.

Topic Closed

This topic has been closed to new replies.

About this Topic