Need help? Check out our Support site, then


Gallery and comments - inconsistent

  1. Hi, when I turn off the comments on the blog post itself, shouldn't the same apply to the gallery and its photographs?

    Please fix this inconsistency. The gallery option currently provides the comment option even though the post itself has comments turned off.

    The blog I need help with is ismailimail.wordpress.com.

  2. You can only have attachment pages with no comment box if you create the post under a no-comments-allowed default (in Settings > Discussion), then override that setting for the particular post after you publish it (post editor > Discussion module > tick “Allow comments on this post”, or Posts > Edit > Quick Edit > tick “Allow comments”).
    http://wpbtips.wordpress.com/2009/04/26/images-the-three-link-options/

  3. I don't understand. I inserted a gallery on a post where I turned the comments off. From what I can tell, the comments should now be off for all the pictures in the gallery as well, but that's not what I saw. The comments were allowed on the individual photographs of the gallery. This seems inconsistent to me and should be fixed by the WordPress. When a blog post is purposefully set to not-allow comments, than this setting should inherit on all aspect of the same blog post.

  4. When you publish a post or a page with a gallery, the so-called "attachment pages" you get when clicking on each thumbnail adopt your default Discussion Settings, not the options you select in the post or page editor.

    Whatever you change in your Settings will apply to posts or pages you create after you've made that change: it won't affect already created posts or pages.

    So the only way to have gallery attachment pages with no comment field is to disable commenting in Settings>Discussion before creating gallery posts or pages, (and override it in the Discussion module of the post/page editor for posts/pages in which you do want to allow commenting).

  5. I see what you're saying but this makes no sense. But thanks for your input. I think i now see that this isn't really a new problem. It has been like this for the gallery for a while and I am just probably noticing it today because I did want to disable a comment on a single post where I inserted a gallery.

    BTW, any idea how does this modlook tag works now-a-days on the support forum? Who has the ability to remove it from the thread and why would it be removed, what is the criteria?

  6. This is the way it has been for a very long time.

    I'm specualating when I say that if Staff feel a question has been rproperly answered, and they have nothing more to add to the answer, then they might choose to remove the "modlook" tag and not respond in the thread.

Topic Closed

This topic has been closed to new replies.

About this Topic