Need help? Check out our Support site, then


Gallery Link To "None" is still opening the image

  1. I'm playing around with a post idea for which I would like to use the Gallery feature. I have used tables in the past to get around the Gallery's limitations but ideally I'd like to just make Gallery work for me if possible.

    What I really want is to be able to specify a Custom URL for each image in the Gallery, but I know that feature is not available. I saw elsewhere in the forums the suggestion to put links in the captions. Happy to see you can insert HTML in that field. Not happy to see that even though it displays as an active link and my browser even displays the correct target in the bottom left corner, upon being clicked it STILL does not go to that link if the carousel slideshow setting is active. So you can click on the image or the caption text and regardless it opens the carousel.

    So I turned off the carousel to see what would happen. Told the Gallery to Link to "None". Sure enough now if you click on the caption it opens the external URL that I want. BUT if you click the image... it opens the attachment page. Argh. I really don't want it to do that, looks messy.

    So what I'm trying to accomplish is the caption opening the new tab with url I specified, and clicking the image itself does nothing, it should not be an active link. (Obviously really I would love for the image to go to my specified url too but I'm not expecting miracles here.)

    Any suggestions?

    The blog I need help with is design-vox.com.

  2. When you set the gallery link option to None, the images aren't clickable. If you inserted the gallery then edited it to select None, you probably forgot to click Update (post) after you clicked Update Gallery.

  3. @timethief: Related, yes, but not exactly what I'm getting at.

    @justpi: The post I've been working with is not published, but I assure you I have been refreshing the preview after every edit. That would be a pretty rookie mistake.

    At any rate, I decided to just abandon the Gallery for what I'm trying to accomplish. It took a while but I got it to look how I wanted without it.

    I still don't understand why when set to "None" the images were still clickable. I just tried it again with a fresh new Gallery, set it to "None" right from the beginning, and the images are still clickable and go to the attachment page. Perhaps it's something with the coding for my theme not allowing that setting.

  4. Galleries work the same no matter what the theme.
    If you switch the editor to "Text" you should see the gallery shortcode. Could you please paste the shortcode here?

  5. Here's the shortcode:
    [gallery type="square" link="none" ids="10507,10516,10515,10514,10509,10508"]

    What Jen said in that thread definitely relates directly to this. Sounds like I am not crazy and this is a bug. Oh well, like I said, I just opted to not use the Gallery to get around the problem. I think what I accomplished honestly looks better anyways. The grid of images at the end of this post: http://design-vox.com/2013/12/20/shopping-weddings-on-etsy/

  6. By the way thank you for your help.

  7. We've been able to add links in image captions and image descriptions for a while now, but linking Gallery thumbnails to "None" will only work when using the default Thumbnail Gallery and so far only when the Photo Carousel is turned off. Not the best of all worlds by far.

    Also, thanks for adding your voice to this thread http://en.forums.wordpress.com/topic/link-gallery-images-to-pages-and-or-posts-or-external-url?replies=2

Topic Closed

This topic has been closed to new replies.

About this Topic