Need help? Check out our Support site, then


Gallery Problem with IE 7

  1. I added some images on my blog, through the gallery but not display them correctly:
    1.2
    3
    4.5
    6
    7
    Instead of:
    1.2
    3.4
    5.6
    They are not properly displayed,on my Broser IE
    Thank you!!!

  2. Complete link to your blog please.

  3. http://nickfree.wordpress.com/

    If you used the Gallery feature to insert your images, the default display of thumbnails is 3 per row. For some reason your thumbnails aren't being resized to the correct the which is probably why you are getting the above display. (Also in FF by the way)

    You can change the number of columns Gallery displays by modifying the shortcode [gallery columns="2"] Taken from this:
    http://codex.wordpress.org/Using_the_gallery_shortcode

    Just as an aside, your photos while great are HUGE, which makes loading time terribly slow. Maybe think about resizing them before uploading to your blog?

  4. d-Oh! "to the correct the which is probably why" should have read "to the correct width, which is probably why..."

    More coffee!

  5. I have change resoluzion of images, excuse me for this, and code of gallety '[gallery columns="2"]' , don't display two columns but one ?!?

  6. I don't have IE7 Nick, but that's the way it's displaying in IE6 too, one photo per row. After uploading the photos, did you indicate any alignment or leave it at "none"?

    FWIW-looks fine in FF2.0.0.16

  7. @justjennifer: Looks fine now because apparently Nick corrected it - in the morning it was one column. I would like Nick to tell us what he changed, since I had looked at the source code of his post and the code for the gallery seemed ok to me.

  8. @panaghiotisadam-are you looking at Nick's entry with IE6 or IE7? For me it's still displaying 1 column in IE6.

    In FF it's OK.

    I'm guessing this is a CSS problem specific to IE. (shudder)

  9. None of the two: Firefox and Safari, on a Mac. But I guess you're right, anyway. (But then again, Nick's source code for the whole post is a lot different now than it was in the morning.)

  10. I have indicate alignment on the left. I have tried has also indicate columns 3 and displays as I described in the first post

  11. Nick, no need to indicate alignment for your Gallery images. The Gallery shortcode should automatically take care of that. What the shortcode should look like in your Editor is:

    [ gallery columns="2" ] (without the spaces after the first bracket and before the second one)

    That automatically generates this code in your Post
    `<style type='text/css'>
    .gallery {
    margin: auto;
    }
    .gallery-item {
    float: left;
    margin-top: 10px;
    text-align: center;
    width: 50%; }
    .gallery img {
    border: 2px solid #cfcfcf;
    }
    .gallery-caption {
    margin-left: 0;
    }
    </style>`

  12. I have put out the left aligment on gallery, and correct the code, but display incorrect.

Topic Closed

This topic has been closed to new replies.

About this Topic