Need help? Check out our Support site, then


Gallery -- Removing images

  1. Okay--this has to be simple to do. I have read support document and perused the forum, but cannot find the answer.

    I have upload four pictures. Two I want to put in the post individually, two I want to use via a gallery and have them side by side. I cannot find a way to insert the gallery without all four pictures appearing! There has to be a simple way to select what pictures you want to appear in the gallery, right? Surely I am overlooking something simple....

    I cannot delete the images because I want to use them individually in another part of the post? Or does "delete" under the gallery tab only remove it from the gallery? Kind of like using the delete key when you want to remove a song from a playlist in iTunes.

    I hope my question makes sense...

    Please help!

    The blog I need help with is armchairanglers.wordpress.com.

  2. panaghiotisadam
    Member

    You can exclude individual images. See here:
    http://en.support.wordpress.com/images/gallery/

  3. To delete an image from the Gallery, open the Image Uploader Gallery tab, click on “Show” and then click on the “Delete” link that appears beneath the Description box. You’ll be asked again if you want to delete the image. Click “Continue”. The image is deleted not only from the Gallery, but also from your Media Library.

    reference > http://gammagirl.wordpress.com/2008/07/27/not-the-official-wordpresscom-gallery-faq/

  4. Currently, galleries work by including all of the images that are attached to a given post or page. So, here's what Jennifer says you can do:

    Upload images you want to include in the gallery from inside the post while you are editing. Then upload images that you don't want to include in the gallery from the Media Library > Add New page. Images added that way will be unattached and you can add the unattached images from the Media Library into the content areas of the post without including them in any gallery.

    You can also exclude images from being included in the Gallery by ID number. This has to be done in the HTML editor.
    http://en.support.wordpress.com/images/gallery/#gallery-shortcode

  5. I apologize, in advance, if what I posted above confuses you. I find all this image and gallery management stuff to be extremely frustrating and annoying, therefore, I do not use the gallery function at all. My images are unattached and I use HTML tables to align and display them. If you want to do that as well here are two posts you can consult.
    http://onecoolsitebloggingtips.com/2008/03/31/how-to-make-html-tables-for-your-wordpress-blog/
    http://onecoolsitebloggingtips.com/2010/03/24/align-images-html-tables-for-wordpress-blogs/

  6. It seems that this feature is under development. Yesterday I could exclude an image with the shortcode. Image ID yesterday was a number, but today there is not that number in the URL of the image page. The image excluded is still excluded, but I don't know how to do it again.

    You can see the topic in Spanish forum here (latest replies):
    http://es.forums.wordpress.com/topic/las-diapositivas-no-se-cargan?replies=10

    (The gallery I am talking about is in a private check blog)

  7. @bocraw- @ludusnaturae-The image ID number is not in the URL of the image page. It can be seen when you hover your mouse over the image, its title, the word "edit" or "delete permanently" in the Media Library.

    When you hover the mouse over one of the above, look at the lower left-hand corner of your browser window and you will see something like yourusername.wordpress.com/wp-admin/media.php?attachment_id=XXXX&action=edit

    The Gallery shortcode has to edited in the HTML Editor after inserting it in the Post or Page; it's that highlighted number which needs to be mentioned in the exclude. See here
    http://en.support.wordpress.com/images/gallery/#gallery-shortcode

    @tt-I know it's confusing. But now that we are able to exclude an image from the Gallery even when it's uploaded with other photos to the same post or page, it's a little easier. My FAQ has been updated to reflect this.

  8. Thanks a lot, justjennifer!
    I was going crazy looking for this ID! Really it's not easy to find it.

  9. Wow! I just had exactly the same problem! So thank you, bocraw, for doing the asking for me and thank you timethief for yet another brilliant answer! The table worked perfectly but I don't think I will tackle that hassle soon again. Todays post will have to be enough for a while on the image heavy front. ;D

  10. @Jennifer
    Thanks for wading in. I don't normally curse. However, I refuse to spend one more second of my valuable time trying to figure how to work with that #$@^&* gallery! My HTML tables do a great job of displaying images exactly the way I want them to display. 'Nuff said because if I even hear the word "gallery" I'm tempted to publish a scathing post on this subject replete with colorful language. lol :D

  11. @taletellerin
    Your HTML image table looks good. :)

  12. @ludusnature-Welcome!

    @tt, feel free. There is certainly room for improvement. :)

  13. @timethief! Thanks a lot! And thanks again for your table - it totally saved my day.

    @Jennifer Good to know that the editing is possible in the gallery but wow. The gallery function itself certainly doesn't even hint at it. Or I'm just really blind. ;D

  14. As always, thank you all for the providing multiple work-around options!

  15. I love the gallery feature! Why bother with an HTML table when the gallery does it for you?

    The only problem with the gallery feature is its support article (http://en.support.wordpress.com/images/gallery/), which neglects to explain how to find the attachment ID of the picture you want to exclude. Thank you thank you justjennifer for explaining! That information really should be added to the support article.

  16. I am working with the newest wordpress version, but the exclude option is not working for me.
    For example the following code will not exclude the image with the id 723

    [gallery exclude="723"]

    So, what could be the problem here?
    would appreciate some hints

  17. @philllie1
    Please post the complete clickable URL for the blog your are referring to starting with the http:// prefix

Topic Closed

This topic has been closed to new replies.

About this Topic