Need help? Check out our Support site, then


Gallery thumbnails. Make same size!!!!!!!!

  1. Have been trying for about 3 hours now to get photos on my blog in an arrangement that makes the thumbnails all the same size and am unable to, no matter what code, size setting etc I put in. Driving me mad, can anyone help please. I would like a static page with 9 images, all the same size, if you click on one then go to slideshow. I would like to repeat this on other pages. Have tried 4 different themes and can't get any of them to work. The help section on Gallerys shows everything uniform, it just doesn't work that way. Help please?

    The blog I need help with is secondintime.com.

  2. What size have you set here? > Settings > Media
    The sizes listed there determine the maximum dimensions in pixels to use when inserting an image into the body of a post.

  3. Have uploaded photos all same size and tried lots of different sizes in settings and they never display in line and the same size. Have gone for layout that doesn't matter now but it's not how I want it. The next problem I am having is that the page does not display on iPhone or iPad properly. So looking like I will have to start again anyway with a different theme. WordPress is great, but not as straight forward and easy as its made out to be.

  4. Hi-it looks to me like you've enabled the "Display all your gallery pictures in a cool mosaic" under Dashboard>Settings>Media>Image Gallery Carousel. If you want your Gallery images to appear in the default thumbnail grid layout instead, uncheck that box and save your changes.

    You can see what the default thumbnail display looks like here, at the very bottom of this page:
    http://en.support.wordpress.com/images/gallery/#examples-of-gallery-styles

    Unasked for suggestion/
    At the moment, your Portfolio page is empty. Why not add a thumbnail image and a link to the other child pages?
    /suggestion

  5. Thanks, I have that option ticked as if unticked it shows all thumbnails different sizes and spread all over the place. Have tried every setting I can find, Have even uploaded all photos again cropped the same size and it will still not display thumbnails the same size, in neat columns and rows.

    Thanks for the suggestion, I will look at that, have the portfolio tab as a drop down now so as to select the types of images.

  6. As long as we're both online, could you uncheck it and then let me have a look? Maybe I can suggest something? :)

  7. ok, just unchecked it, it doesn't look anything like the example in the link you sent, uniform in size and close to each other etc, not sure I want to change it now, got used to the mosaic look. Sorry. Have a look anyway.

    Have added some links on portfolio page for now, thanks for that, never thought about someone clicking the portfolio tab without looking at the drop down list of other pages first. I will do more on that page, just wanted to get the links on for now.

  8. Hm, ok. On your front page, try reducing the number of columns to 3 rather than 4. It will help with the spacing. As it is, there are too many columns to fit the thumbnail images there.

    There's other ways to adjust the Gallery settings if you feel comfortable playing in the Text Editor tab. You can drop to two columns and enlarge the size of the image displayed by adding this to the Gallery shortcode between the brackets:
    columns="2" size="medium"

    The reason the Gallery isn't uniform is because your uploaded images aren't uniform. Some are Portrait, Landscape or Square and they don't have a consistent ratio. To overcome this, you can add type="square" to the Gallery shortcode to have WordPress.com generate evenly square, cropped images which will then cover the entire width of the posting column.

    But I do agree that the mosaic is also nice. If none of these are to your liking, remove any extra code and head back to the mosaic. :)

  9. One thing I should mention is that when you use the mosaic, square or circle type in your Gallery, the "columns" and "size" parameters are entirely ignored. The Gallery will go the entire width of your page or post's content area.

  10. Sorry! That should have read "when you use the rectangle (mosaic), square or circle type..."

  11. Thanks for the info, will pop mosaic back on for now and I will give it a try a bit later to see which I prefer. Thanks for your help, very much appreciated.

  12. You're welcome. If you want more info about working with the Gallery feature, http://gammagirl.wordpress.com/2008/07/27/not-the-official-wordpresscom-gallery-faq/ which I've updated to reflect the changes in media handling and there are demos here: http://agallerydemo.wordpress.com/ which have not yet been updated since I'm waiting for the dust to settle after the change. The info on Gallery types, however, is still correct.

Topic Closed

This topic has been closed to new replies.

About this Topic