Need help? Check out our Support site, then


Getting comments/replies on my blog

  1. When trying to posts reply or comment the user is asked for email address or login.

    I have turned this off in the 'settings/discussion' section by unchecking 'comment author must fill out name and email' and also unchecking 'users must be registered and logged in to comment' but when I try this out, it still asks me to sign in or enter details.

    The blog is not only shown in WordPress, but is also on the website. It's comments from the website I wish to invite, but not to make people register or sign in.

    The blog I need help with is getrealvideo01.wordpress.com.

  2. This page > Settings > Discussion is where you set up defaults for comments.
    http://en.support.wordpress.com/settings/discussion-settings/

    Discussion Settings
    Other comment settings
    _Comment author must fill out name and e-mail
    _Users must be registered and logged in to comment

    Note that the prompt will still appear but providing an email address and logging in are not required. You can post instructions for your visitors in a text widget if you wish. That's easy to do. You copy and paste this into a text widget:

    Readers: Note that the email address and logging in prompts do appear for comments but providing an email address and logging in are not required.

    See here and read about how to set up a text widget. http://en.support.wordpress.com/widgets/text-widget/

    P.S. if you set up the blog for anonymous commenting then do be sure to set up full comment moderation ie. "An administrator must always approve the comment" because anonymous commenting is bound to increase the amount of spam your blog will receive.
    http://en.support.wordpress.com/settings/discussion-settings/#comment-moderation

Topic Closed

This topic has been closed to new replies.

About this Topic