Need help? Check out our Support site, then


Google Apps Changed Procedure; Cannot Set Up Email for Mapped Domain

  1. It appears that Google has changed its security procedures for email set-up through Google Apps. This thus obsoletes the WordPress set-up instructions [ setup your email through Google Apps for Domains: http://en.support.wordpress.com/domain-mapping/google-apps-email/ ].

    Specifically, the verification codes generated by Google now look nothing like those in the example -- and those on the actual DNS settings page. The codes actually generated by Google were rejected by the DNS Records Page.

    Without access to my site's home page code as Google recommends, and with no ftp access to the actual site, as Google suggests, I have no way to set up email connectivity for my newly mapped domain on WordPress.com. YIKES!

    :-(

    Please help.

    Thank you.

    Don

    P.S. The new format is a text string [ changed a bit here ] : google-site-verification=W4b23NEA2XjasreSwASDFLKJEQytr8oiu_n78r-PtR for pasting in the DNS record.

    The blog I need help with is growanddevelop.com.

  2. I've tagged this thread for staff attention and hopefully they will be by shortly and reply and get things going for you.

  3. Im having the same problem. :( hopefully it gets sorted soon

  4. Have you tried entering just the verification part of the code into the field as detailed in step 7 of the guide?

  5. I just ran through the whole process myself and everything worked out exactly as detailed in the guide at http://en.support.wordpress.com/domain-mapping/google-apps-email/

  6. Thank you for confirming the set-up.

    And I sure am baffled. The screen shots and procedure in that guide (which I had up on the screen) look nothing like what Google presented me with. Maybe an A/B test?

    Now, because I went on to other things in the past 24 hours, Google no longer presents me with the original set-up options. It expects that I have normal site administrator rights. You know, access to the code of a page to insert something in a heading, or capacity to change a DNS setting, or capability to FTP to the site. Usual stuff. 'cept here.

    So now I'm stumped (and thwarted) twice.

    I don't know how to verify / validate the site now. As far as Google is concerned, I am a potential intruder.

    Suggestions?

    Thanks for your help.

    Don

    ...........................................................................................

    For the record, I've been making web sites since '94 (table row, table data). So not a neophyte. I came to WP.com because I thought it would be nice to 'leave the driving to someone else.'

    Maybe that's a mistake. I can't even send screen shots to this forum to show you what I saw in the Google set-up --> which was radically different than in the guide which I was staring at through the whole process (mystified at the mismatch). I simply was not presented with the options as represented in the WP support guide.

  7. I cleaned up the doc just a bit so it flows better.

    Despite already creating the account, you should be able to start the verification again from step 7.

    It is entirely possible that they are A/B testing, which is unfortunate. Assuming that the doc covers the A, I have yet to see the B. Hopefully they'll settle on something soon.

  8. @drd0n - for screen shots - save them and then upload them to your media library then post the link to the file.

  9. Thx for your responsiveness. I have gotten to the Google Apps admin page and see EXACTLY the options shown to me during initial set-up last night.

    You all should take me up on my offer for a screen shot. It does not square with your current procedures. The code generated is different and your system rejects it.

    You have automated for my security. So has Google. But the two are not intersecting.

    Btw, this could be I-d-10-t error on my part. I am a PhD candidate but not a web security expert. I am willing to offer visual evidence...

  10. Screen shot available here: http://growanddevelop.files.wordpress.com/2012/01/google_apps_security_shot.png

    The "Recommended Method" in the tab shown in this shot (copied verbatim from the Google Apps screen):

    Recommended: Add a meta tag to your site's home page
    You can use this option if you are able to edit your site's HTML.
    Instructions:
    1. Copy the meta tag below, and paste it into your site's home page. It should go in the <head> section, before the first <body> section.
    <meta name="google-site-verification" content="zxzxzxzxzxzxzxzxzxzxzxzxzxzxzx" />
    Show me an example
    2. Click Verify below.
    To stay verified, don't remove the meta tag, even after verification succeeds.

    Hope this helps.

    How to proceed?

  11. @drd0n
    I'm just letting you know that I have flagged this thread for Staff attention.

  12. Still in need of help...

  13. Understood and the flagging is still in place.

  14. Wow, that's a very old verification screen. I hope they aren't going back to that.

    Do you have anything besides "Other" in that drop-down menu? If so, what are your options?

  15. The drop down is just for instructions for domain hosts such as Go Daddy, 1-to-1, etc. with customized instructions on how to insert the code on their DNS pages.

  16. Hm, ok then.

    Try adding this to your Custom DNS panel:

    MX 20 ALT1.ASPMX.L.GOOGLE.COM.
    MX 20 ALT2.ASPMX.L.GOOGLE.COM.
    MX 10 ASPMX.L.GOOGLE.COM.
    MX 30 ASPMX2.GOOGLEMAIL.COM.
    MX 30 ASPMX3.GOOGLEMAIL.COM.
    MX 30 ASPMX4.GOOGLEMAIL.COM.
    MX 30 ASPMX5.GOOGLEMAIL.COM.
    TXT google-site-verification=W4b23NEA2XjasreSwASDFLKJEQytr8oiu_n78r-PtR
  17. I receive a pop-up from WordPress.com saying

    Your Google validation string should look like this:
    googleffffff12345

    So still stuck.

  18. And I DO appreciate your help!

  19. Even when you just paste that entirely into your Custom DNS panel (skipping the verification code field)?

  20. More specific information. The error message in the Custom DNS Records reads:

    (1) google-site-verification=Q4...

    1. This does not match any of the DNS record formats.

    == == == == == == == == == == == == == ==

    The error message in the pop-up window reproduced in my earlier post, was triggered by pasting the Google Verification code into the WordPress verification code box.

    Put very simply:

    WordPress is expecting a code that looks like:

    googleffffff1234

    While Google is generating a code that looks like:

    google-site-verification=W4b23NEA2XjasreSwASDFLKJEQytr8oiu_n78r-PtR

    That's quite a spread. ;-)

  21. Ok, this is rather odd and a bit frustrating.

    What Google is showing you now is a very old verification method. They discontinued it a year ago, and in response we changed our documentation and verification method on this end.

    Do you see any other options when you click the "My Verification Code is" link in the Custom DNS panel, or is that just it?

  22. I appreciate the situation. Yes, strange.

    While Google does present a few different methods for them to read the code but none that will close the loop. I CAN get Google to generate an HTML file that includes the code that WP will accept on the DNS code line BUT Google wants the whole HTML file placed on its server.

    Step by step saga between the dots verifies the procedure. Skip it if you want my suggestion below.
    ...........................................................................................

    Listed as Upload an HTML file to your server, Google instructs:

    1. Download this HTML verification file. [googleXXXX.html]
    2. Upload the file to http://growanddevelop.com/
    3. Confirm successful upload by visiting http://growanddevelop.com/XXXX in your browser.
    4. Click Verify below.
    To stay verified, don't remove the HTML file, even after verification succeeds.

    That HTML file has the code in the format that WP accepts. It was able to copy it and enter it into the WP DNS record.

    BUT BUT BUT Google will not accept it as verification. It is looking for either the HTML file it generated OR the much longer string of code it generated that WP has embargoed me from entering.

    After entering the code that WP will accept, generating the DNS record, and selecting Verify at Google, The Google returns a big red block: We weren't able to verify your domain: growanddevelop.com.

    ...........................................................................................

    After, some 20 messages here (all the information is exactly the same as the first one I posted), and since y'all don't allow one to upload html, to edit DNS, yada yada yada, how about you provide me an email address so that I can email you or an authorized representative the code so that somebody can put the dang thing in the record. Someone has to trust somebody here.

    Isn't that reasonable?

    Thanks again for your help.

    Don

  23. Either way, the file can't be added, even by us.

    I'm passing this on to our team to see if there's anything that we can do.

  24. Yes, I do!

  25. Excellent! Use that as the verification code, and the DNS records generated should work.

  26. SUCCESS!

    Thank you!

    Whew.

    That work-around did the trick.

    Thanks for hanging in there with me.

    Appreciate your patience and perseverance.

    Don

  27. You're welcome!

Topic Closed

This topic has been closed to new replies.

About this Topic