Need help? Check out our Support site, then


Google Maps

  1. Hi,

    I've tried this question before but got no replies...

    I have 2 blogs where i frequently use google maps to diplay points of interest.

    up until a month ago everything work perfectly but now I can't get the maps to show in the blog posts.
    I am copying the <iframe> code from maps to wordpress and paste it as instrycted (as I've always done) but it does not show in my posts.

    when i look at old posts where it do work I can see that the code is very different.

    Here I have an old post where it works: http://traveloso.wordpress.com/2013/07/27/guide-rome-trastevere/

    and the code looks like this:
    [googlemaps https://maps.google.com/maps/ms?msa=0&msid=208844082944764403414.0004db2c0b2f18aec220f&ie=UTF8&t=m&source=embed&dg=feature&ll=41.894355,12.486134&spn=0.051112,0.137157&z=13&output=embed&w=800&h=400]

    Here is a new post where it doesn't work: http://runtklotet.wordpress.com/2013/08/02/roadtrip-seattle/

    Code looks like this `<br />
    <br /><small>View <a href="https://www.google.se/maps/ms?msa=0&msid=208844082944764403414.0004c49cbf4278e21bbf2&hl=en&ie=UTF8&t=m&ll=47.633656,-122.349887&spn=0.068952,0.07167&source=embed" style="color:#0000FF;text-align:left;">Seattle</a> in a larger map</small>`

    Can anyone please help me with this - it's driving me mad...

    The blog I need help with is traveloso.wordpress.com.

  2. You have several different fonts in the post that doesn't work. This makes me think you've somehow introduced HTML errors and they might be causing this.

    Go to Settings->Writing and select "Wordpress should correct invalidly nested XHTML" and save. Then edit that post, making any change at all.

    Then try re-embedding the Google Map. See if that helps.

  3. Raincoaster: I tried your solution but no change. The map still does not show.

    I really don't understand why it transform to a different kind of code than it used to do...

    Is there any other possible solution you can think of?

  4. Well, staff have been tinkering with themes but that should not have an effect on this. For now I suggest you take a screenshot of the Google map and upload that instead. At least it will look consistent. And maybe overnight someone else has some ideas?

  5. Hi, I have the same problem and can't figure out why!
    I thoroughly followed the instructions here: http://en.support.wordpress.com/google-maps/

    But everytime I save the post the iframe code just disappears instead of changing to [googlemaps... ] like it says in the instructions.
    Can't anyone from the staff give a help on this?

    I'm using the Fresh&Clean theme if that's of any help.

  6. If the code disappears instead of converts into something else, are you putting it in the Text editor like the instructions say or the Visual editor?

  7. Hi raincoaster, yes I am putting it in the Text editor. I've been following the instruction word for word! :(
    I've tried it a dozen times now even closing the blog and re-opening it.
    I also tried to paste the code in a brand new blank post page but got the same result: the entire <iframe> code gets stripped.
    As far as I know the <iframe> tag is not allowed in worpress.com posts but the google maps should be some kind of exception.
    It looks as though the exception is not recognized so the code just gets stripped off.

  8. Well, I'm out of ideas. I am flagging this for staff to figure out.

  9. Thanks raincoaster.
    I also found this other thread reporting the same problem: http://en.forums.wordpress.com/topic/issues-with-adding-google-map-to-my-blog?replies=6
    The frustrating thing is that up to now people say they "solved" the issue not knowing how... which is of little help!
    Hope to get some feedback soon.

  10. HI stromstrom and forthose,

    I just tested the Google Maps feature and it is indeed working properly.

    What I did: I went to Google Maps and decided I wanted directions to the Eiffel Tower.

    When the map popped up, I chose the link icon: http://cl.ly/image/2Q2T1a1l1K2Q

    It gave me two different link options. I chose the second one, and copied it to my clipboard: http://cl.ly/image/0T2Q0s1M2H18

    From there, I opened a new post, chose the TEXT editor tab rather than the Visual tab, and pasted the code in. It looked like this: http://cl.ly/image/1Z1J0F1h2j1h

    When I published the post, the code automagically transformed into a Google shortcode: http://cl.ly/image/3l3f1G0e0T3J

    I also tried this with the Zoren theme, which is the theme running on runtklotet.wordpress.com, as well as the Fresh and Clean theme. Both worked fine.

    This is how the map appears: http://cl.ly/image/3u1W2u2Y1J08

    There are a number of places things could go wrong: 1) Copying the first code in the Google map generator 2) Clicking the button "short URL". 3) Possibly, the customize map feature (I didn't test that) 4) Copying any other map code 5) Inserting the code into the Visual rather than Text editor 6) Modifying the code after it switches to a short code.

    Could those of you having issues review my steps and try to reproduce them, and let me know how it goes? If you're still having trouble, it would be especially helpful if you could link me to the blog post (you can just save it as a draft or publish privately) so I can see what your code looks like.

  11. Hi jackie,
    alright, so after trying all the steps you (and the help topic) suggest a dozen times on my work PC I just did the same at home and... TADAAA... it works!
    As a matter of fact I wanted to try another computer earlier but didn't get a chance.
    I'd like to try again tomorrow on another PC from work just to make sure it's the PC.
    I have a feeling that rather than that, it could be the connection.
    The work connection goes through some proxy server based in Switzerland (I'm based in Italy) so it could be that the iframe code doesn't get through to the wordpress servers so it doesn't get processed somehow.
    I'll post again tomorrow. It could come useful for some other user in this same particular situation!
    Thanks for caring! ;)

  12. Hi forthose,

    I would love more troubleshooting on this issue. It could be that you're right, and when the page reloads to display the correct shortcode, something gets gummed up in the process. I'm not sure if we can fix that easily if that's the case, but it would be good to know.

  13. Hi all,
    Thanks for the help.

    For me the problem seem to be Google Chrome. I use this on my work computer (PC) and at home I have a Macbook air where I use Safari.

    So today at work I tried using my work computer but I re-pasted the code in Firefox instead and it worked.

    Very strange...

    I hope this helps others out there who encounter this problem - switch from Chrome as your browser (which is sad because Chrome is by far my favorite)

  14. Hi stromstrom,
    now I'm really puzzled!
    I used Chrome both at work and home and it worked last night at home.
    So I thought the browser can't be the problem but I tried changing it here at work this morning anyway. And it worked (IE Explorer)!
    So, just to be sure I tried it on Chrome again and... it works!! =:0
    At this point I really wouldn't know what to think. There doesn't seem to be any pattern and - as other users reported - it just seems to magically go on or off.

  15. That is very strange.

    I used the exact same computer that I've used the last times when it didn't work and today there is no problem when I use Firefox instead of Chrome.

    I'll try it at home tonight and see if there is any change.

    How can the <iframe...> code transform to 2 different versions?

  16. Hi stromstrom and forthose,

    If you continue to have problems with this, please save as a draft a post with the non-functioning code, and post the iframe code you got from Google and then the (not working) googlemaps shortcode here in entirety. It would also help to have the address you used to create the map. Essentially, I'd like all the bits so I can try to reproduce it, and if I can spot any obvious places where it's falling apart, I can let our developers know.

  17. I've got the same problem… Google may have changed something though…

    Original code:
    <iframe width="425" height="350" frameborder="0" scrolling="no" marginheight="0" marginwidth="0" src="https://www.google.fr/maps?t=m&q=Kitokito&dg=opt&ie=UTF8&hq=Kitokito&hnear=Asni%C3%A8res-sur-Seine,+Hauts-de-Seine,+%C3%8Ele-de-France&z=14&iwloc=A&cid=15985986045963242350&ll=48.838669,2.308899&output=embed"></iframe><br /><small><a href="https://www.google.fr/maps?t=m&q=Kitokito&dg=opt&ie=UTF8&hq=Kitokito&hnear=Asni%C3%A8res-sur-Seine,+Hauts-de-Seine,+%C3%8Ele-de-France&z=14&iwloc=A&cid=15985986045963242350&ll=48.838669,2.308899&source=embed" style="color:#0000FF;text-align:left">Agrandir le plan</a></small>

    What's left:
    <br /><small><a href="https://www.google.fr/maps?t=m&q=Kitokito&dg=opt&ie=UTF8&hq=Kitokito&hnear=Asni%C3%A8res-sur-Seine,+Hauts-de-Seine,+%C3%8Ele-de-France&z=14&iwloc=A&cid=15985986045963242350&ll=48.838669,2.308899&source=embed" style="color:#0000FF;text-align:left;">Agrandir le plan</a></small>

    It seems it does like my iframe at all!

  18. Hi tchizbeurgueur,

    Did you see the iframe code transform into a shortcode in your post? Can you send me the link to the post?

  19. No, it hasn't transform in the shortcode. It just got rid of the iframe!
    http://kitokitoparis.wordpress.com/ou-nous-trouver/ (private site at the moment).

  20. I just tried adding your iframe code and it didn't work for me either. Can you try generating a new code? Also, could you post the address you're using?

  21. https://www.google.fr/maps?t=m&ll=48.917943400000006%2C2.2934611000000005&spn=0.04794255178185118%2C0.09727708761268315&output=classic&dg=opt

    I've tried another address; I've tried to turn the site public just to be sure; I've tried in an article instead of a page; I've tried google.com instead of Google.fr; it still doesn't work and erase the whole iframe.

  22. Hi tchizbeurgueur,

    Does this look like the iframe code you're getting?

    <iframe width="425" height="350" frameborder="0" scrolling="no" marginheight="0" marginwidth="0" src="https://www.google.fr/maps?t=m&ie=UTF8&ll=48.917987,2.293396&spn=0.124537,0.20565&z=13&output=embed"></iframe><small>Agrandir le plan</small>

    <iframe width="425" height="350" frameborder="0" scrolling="no" marginheight="0" marginwidth="0" src="https://www.google.fr/maps?t=m&ie=UTF8&ll=48.917987,2.293396&spn=0.124537,0.20565&z=13&output=embed"></iframe><small><a href="https://www.google.fr/maps?t=m&ie=UTF8&ll=48.917987,2.293396&spn=0.124537,0.20565&z=13&source=embed">Agrandir le plan</a></small></p> <p>
    Can you try pasting it into your page and seeing if it works?

  23. Yes. It still doesn't work… :(

  24. tchizbeurgueur,

    I'm going to be reporting this to our developers.

    For you and anyone else having issues, can you state which browser(s) and browser version you've tried and if it fails in all or just some of them?

  25. Some interesting additional bits:

    1) Now the iframe code I posted earlier doesn't work for me either. Curious.

    2) A colleague pointed out that your address is based on latitude/longitude rather than a specific street address. Have you tried both options, or have you only been using lat/long for your addresses?

  26. Hi tchizbeurgueur,

    We seem to have isolated it to the google.fr address. Trying maps.google.com seems to work. A colleague in Europe switched from the .fr link to the standard Google address and it went from failing to working. Here's code she got to work:

    <iframe width="425" height="350" frameborder="0" scrolling="no" marginheight="0" marginwidth="0" src="https://www.google.com/maps?t=m&q=Kitokito&dg=opt&ie=UTF8&hq=Kitokito&hnear=Asni%C3%A8res-sur-Seine,+Hauts-de-Seine,+%C3%8Ele-de-France&cid=15985986045963242350&iwloc=A&ll=48.838669,2.308899&spn=0,0&output=embed"></iframe><small><a href="https://www.google.com/maps?t=m&q=Kitokito&dg=opt&ie=UTF8&hq=Kitokito&hnear=Asni%C3%A8res-sur-Seine,+Hauts-de-Seine,+%C3%8Ele-de-France&cid=15985986045963242350&iwloc=A&ll=48.838669,2.308899&spn=0,0&source=embed">View Larger Map</a></small>

  27. We seem to have isolated it to the google.fr address.

    I'm not too sure about that.
    I just pasted this:
    <iframe width="425" height="350" frameborder="0" scrolling="no" marginheight="0" marginwidth="0" src="https://maps.google.it/maps?hl=it&ie=UTF8&ll=45.625909,9.444079&spn=0.008148,0.021136&t=m&z=16&output=embed"></iframe><br /><small><a href="https://maps.google.it/maps?hl=it&ie=UTF8&ll=45.625909,9.444079&spn=0.008148,0.021136&t=m&z=16&source=embed" style="color:#0000FF;text-align:left">Visualizzazione ingrandita della mappa</a></small>
    As you can see it's a google.it address and it works fine.

    BTW, I pasted it into the Visual editor by mistake and it worked anyway! :0

  28. Jackie,

    Your code works fine, even with google.fr.
    Is it the latitude/longitude coordinates that don't work?

    Thanks anyway for digging it up for me!

  29. Hey Jackie,

    Still me!

    There is and problem with the new Google Maps, the link to personalized maps isn't the same, so the embedding doesn't work either. This is the new address (Map Engine):

    <iframe src="http://mapsengine.google.com/map/embed?mid=zvN8Mlstj87E.k66vkdygl3yU" width="640" height="480"></iframe>

  30. Hi jackie and tchizbeurgueur,
    adding some more info.
    I tried your codes here at work:
    The original code posted by tchizbeurgueur (google.fr) doesn't work while the code suggested by jackie (google.com) does.
    I also tried another address that I just picked out now (google.it) and it didn't work.
    Here's the code:
    <iframe width="425" height="350" frameborder="0" scrolling="no" marginheight="0" marginwidth="0" src="https://www.google.it/maps?sll=45.57438289999905,9.344801725081147&sspn=0.013502325611045704,0.02746468071620466&saddr=Via+Cassignolo,+Agrate+Brianza,+MB&t=m&daddr=Comune+Di+Agrate+Brianza,+Via+San+Paolo,+24,+Agrate+Brianza+Provincia+di+Monza+e+della+Brianza&dg=opt&ie=UTF8&geocode=FaRbtwIdaoiOACkZ53QeEreGRzGwpHd34eYqWw%3BFSdvtwIda6qOACkpBmAyGLeGRzFuaMD5D9tBCg&ll=45.572539,9.345865&spn=0.007049,0.0106&output=embed"></iframe><br /><small><a href="https://www.google.it/maps?sll=45.57438289999905,9.344801725081147&sspn=0.013502325611045704,0.02746468071620466&saddr=Via+Cassignolo,+Agrate+Brianza,+MB&t=m&daddr=Comune+Di+Agrate+Brianza,+Via+San+Paolo,+24,+Agrate+Brianza+Provincia+di+Monza+e+della+Brianza&dg=opt&ie=UTF8&geocode=FaRbtwIdaoiOACkZ53QeEreGRzGwpHd34eYqWw%3BFSdvtwIda6qOACkpBmAyGLeGRzFuaMD5D9tBCg&ll=45.572539,9.345865&spn=0.007049,0.0106&source=embed" style="color:#0000FF;text-align:left">Visualizzazione ingrandita della mappa</a></small>

    All this using Chrome Version 28.0.1500.95 m

Topic Closed

This topic has been closed to new replies.

About this Topic