Need help? Check out our Support site, then


Google review rich snippets not working

  1. Hello,

    I wanted to use markup in my blogs content for google rich snippets, in particular I'd like to use the micro data markup.

    However whenever I insert the markup into a post, it disappears from the HTML view as soon as I publish or update the post.

    Here is the documentation on the google website about using this markup http://support.google.com/webmasters/bin/answer.py?hl=en&answer=176035

    Thanks

    The blog I need help with is laggacy.wordpress.com.

  2. Because we're a shared platform here, not all kinds of code work here. If you'd like to request that staff enable these codes, I can flag this to be moved to the Ideas forum.

  3. That'll be fine, I'll put a thread in the suggestion section. Thanks.

  4. What is the status of this suggesion?
    I also want to use rich snippet text but can not see a way to do this at my frommtaxes.wordpress.com. Any suggestions as to how to implement rich snippet text?

  5. Ideas posted here linger for years. Now and then one is acted on but that is an infrequent occurrence. So that status of these Ideas threads that are still open (not closed) is they are pending.

  6. Six days? Check back in a year.

  7. So does anyone know if there is a way to implement rich snippet text at this time?

  8. Rich text can be posted using the "Paste from Word" option in the Advanced toolbar. That's been the case for several years.

  9. Below is an excerpt from webmaster tools for implementing rich snippet text for me as author. Can I do this at my blog?
    http://www.google.com/webmasters/tools/richsnippets?url=frommtaxes.wordpress.com

    Google search preview
    Philadelphia Estate and Tax Attorney Blog
    frommtaxes.wordpress.com - Cached
    The excerpt from the page will show up here. The reason we can't show text from your webpage is because the text depends on the query the user types.

    Note that there is no guarantee that a Rich Snippet will be shown for this page on actual search results. For more details, see the FAQ.

    Extracted Author/Publisher for this page
    author (extracted from page content)
    author name = STEVEN J . FROMM
    Are you the author? If you have an email with wordpress.com and verified it with Google+, please enter your G+ profile to verify your authorship here

    author
    linked author profile = http://sjfpc.com/
    Error: Author profile page redirects to another URL

    redirect url = http://www.sjfpc.com/

    Error: Author profile page does not have an authorship link to a Google Profile. Learn more.

    author
    linked author profile = http://www.sjfpc.com/

    I do not know how to implement this in wordpress.com. Is there a way to do this?

  10. I don't want rich text, I want microdata for rich snippet reviews

  11. fdly: Thanks for the response, but I do not understand from it how to solve my problem and questions posed here. Can you give me some specific advice.

  12. I can't seem to solve this problem: Here is the link:

    http://www.google.com/webmasters/tools/richsnippets?user_profile=https%3A%2F%2Fplus.google.com%2F112724554872191616076%3Fgl%3Dus%26hl%3Den%23105642486945545006284%2Fposts&url=frommtaxes.wordpress.com&view=cse

    and an excerpt of this link:

    "Extracted Author/Publisher for this page
    author (extracted from page content)
    author name = STEVEN J . FROMM
    google profile = https://plus.google.com/112724554872191616076

    full name from G+ profile = Steven J Fromm & Associates, PC .
    Error: Author name found on the page and Google+ profile name do not match. Please consider adding markup to the site.Learn more.

    author
    linked author profile = http://sjfpc.com/

    author
    linked author profile = http://www.sjfpc.com/

    author
    linked author profile = https://plus.google.com/112724554872191616076?gl=us&hl=en#112724554872191616076/posts
    google profile = https://plus.google.com/112724554872191616076?gl=us&hl=en#112724554872191616076/posts
    We could not find a link to frommtaxes.wordpress.com from the Other profiles or Contributor to section of your Google Profile to verify this page. Learn more.
    author
    linked author profile = https://twitter.com/sjfpc"

    Can anyone help me fix this? Specific steps to take as I have tried to fix it but have failed.

  13. Here's what I'll type in the editing window
    <div itemscope itemtype="http://data-vocabulary.org/Review"><br /> <h1></h1><br /> <p><span itemprop="itemreviewed">L.A. Noire</span></p><br /> <p>Reviewed by <span itemprop="reviewer">David Blayney</span></p><br /> <p><time itemprop="dtreviewed" datetime="2012-09-04">September 4</time></p><br /> <p><span itemprop="summary">“A pretty good game, needed more varied gameplay elements”</span></p><br /> <p><span itemprop="description">L.A. Noire is a great detective game that included interesting new gameplay elements and was a great game.</span></p><br /> <p>Rating: <span itemprop="value">7</span> out of <span itemprop="best">10</span></p><br /> </div>

    And this is what WordPress will spit out after saving or publishing:
    <div><br /> <h1></h1><br /> <p><span>L.A. Noire</span></p><br /> <p>Reviewed by <span>David Blayney</span></p><br /> <p>September 4</p><br /> <p><span>“A pretty good game, needed more varied gameplay elements”</span></p><br /> <p><span>L.A. Noire is a great detective game that included interesting new gameplay elements and was a great game.</span></p><br /> <p>Rating: <span>7</span> out of <span>10</span></p><br /> </div>

    All of the itemprop attributes are removed.

  14. In this case I'm using microdata

  15. I've pretty much established that only microformats works, so microdata doesn't. Thanks for posting the rich snippet tool link

  16. laggacy: I am confused by your comments. They are not relate to my questions and issues, correct?

  17. A) you need to make sure that your WordPress.com display name is the same as your Google+ profile name. Make sure that on the link you set rel="author" in your link tag using the HTML editor.

    The final code should be <a href="https://plus.google.com/112724554872191616076" rel="author">My Google+ Profile</a></p> <p>On your Google+ profile you need to edit your profile and add your custom domain name (http://sjfpc.com/) to the "contributor to" section and set it to public.</p> <p>I hope this will help with the authorship markup, this will make your profile picture appear next to search results for pages with this code on it.</p> <p>Is that all you needed help with?

  18. This blog http://sjfpc.com/ is not a free hosted WordPress.com blog.
    For clarity > http://support.wordpress.com/com-vs-org/

  19. Sorry I made a mistake,mother final code on your website should be this:
    <a href="https://plus.google.com/112724554872191616076" rel="author">My google profile</a>

  20. *my final code
    iOS auto correct strikes again

  21. Timethief and legacy: I am now even more confused by your interplay. Can either of you tell me how to do this correctly and clearly with specific steps?

  22. If I am going to "
    Create a link to your Google+ profile from your webpage, like this:
    GoogleReplace [profile_url] with the your Google+ profile URL, like this:
    <a href="https://plus.google.com/109412257237874861202?
    rel=author">Google
    Your link must contain the ?rel=author parameter. If it's missing, Google won't be able to associate your content with your Google+ profile.

    Where do I insert this code into my wordpress blog? Do I set up a link or do I use a widget or what?

  23. Just a link to your google plus profile with ?rel=author at the end of the URL.

    It just needs to be a link, not a widget.

  24. The tag that was in the google documentation is an anchor tag, used for links.

  25. I put a (private?) link to my profile at google plus at wordpress as a link that looks like this: https://plus.google.com/112724554872191616076?gl=us&hl=en#105642486945545006284?rel=author

    But I got this back with the following errors:

    http://www.google.com/webmasters/tools/richsnippets?user_profile=https%3A%2F%2Fplus.google.com%2F112724554872191616076%3Fgl%3Dus%26hl%3Den%23105642486945545006284%2Fposts&url=frommtaxes.wordpress.com

    Is it that they are linking to my PC account at google + and not my individual google + profile?
    what can I do to correct this?

  26. Can someone please flag this thread to be moved to the support section.

  27. drmartinrussell
    Member

    I'm having the same problem with

    "Error: Author name found on the page and Google+ profile name do not match. Please consider adding markup to the site.Learn more. "

    Google knows me as Martin Russell, but my site is set up with my user name of Dr Martin Russell - and this is not a match.

    Anyone suggest what I can change to make them link up?

Topic Closed

This topic has been closed to new replies.

About this Topic