Need help? Check out our Support site, then


Google Search of Blog Post - Not Showing

  1. I have had my blog up and running since early May and while it took a while for my posts to show up in Google Search, once they started to appear they have been visible to Google Search very quickly. Yesterday (August 26th my time) I made a new post and noticed within a few hours that it was visible at Google Search. However now it is invisible, as is the newer post that I made today. Why would this be so? Am I being ... and I shudder to think - censored?

    The blog I need help with is rossbmedia.wordpress.com.

  2. Probably it's something that's changed on Google's end. If you want to be sure, double check your feed with a feed validator to make sure it's okay, and check your blog for errors that can interfere with Google and other search engines by using http://ismyblogworking.com

  3. Thank you, Raincoaster. I checked the ismyblogworking site but it is working fine apparently ... however I find no results for the posts I put up today (Friday) and yesterday (Thursday). But the post I put up on Wednesday has been visible on Google Search for well over 24 hours - probably 48 hours now.

    The Thursday post should be visible with these as a combined Search term ... "ken duncan" + uluru + baloney - but I cannot see it on Google. Very frustrating. Especially when I could see that post via Google Search approx. 24 hours ago.

  4. I feel your pain. Two thousand of my posts are invisible to Google right now, and many people are reporting issues.

  5. The Thursday post should be visible with these as a combined Search term ... "ken duncan" + uluru + baloney - but I cannot see it on Google. Very frustrating. Especially when I could see that post via Google Search approx. 24 hours ago.

    There is no technical reason I can find as to why a specific post or page on your site would not be visible to Google for indexing or why it would not appear in search results. Everything appears to be configured properly.

    Your posts are also appearing as expected in our site indexes and global tag pages here on WordPress.com.

    Indeed, several of your posts about the park are showing in Google's index, but not the one in particular you are mentioning here. You can see this by running this search:

    site:rossbmedia.wordpress.com uluru

    The most recent post in that result is from the 25th, so it's possible that the index has been rolled back or that the initial search caught it and Google does something weird to it. Unfortunately, Google can be a bit of a mystery sometimes—to us as well.

    Have you tried enabling and using Google Webmaster Tools? They can be very valuable for learning more about how Google sees your site and parses it, including the frequency of indexing. You can learn more about how to enable it for your WordPress.com blog here: http://en.support.wordpress.com/webmaster-tools/

  6. These are results similiar to mine. For many of my posts, even the exact title returns no Google result, while typing in just a few words gets it when using the blog-specific search here at WordPress.com.

Topic Closed

This topic has been closed to new replies.

About this Topic