Need help? Check out our Support site, then


Google's +1 button not appearing on my blog

  1. Okay I know WordPress.com has the Google +1 sharing button within the sharing settings of a user's dashboard at Dashboard, Settings, Sharing and have enabled it. It appears in my live preview and until today it was showing on my blog when visiting it but now it seems to have disappeared. What gives? In sharing settings it still appears in the live preview but does not appear on my blog. It used to do so but just stopped. By the way I have a lot of sharing buttons set up taking a lot of space. I have seen some blogs have 3 or 4 individual sharing buttons and then a sharing button titled More and when you click on it you can choose between a number of other social network to share with. For example I mouse over the "More" button it brings up a drop down menu with sharing buttons for LinkedIn, Digg, Reddit etc.

    If you see the sharing buttons at the bottom of this linked page you'd be able to see what I mean: http://en.blog.wordpress.com/2011/08/19/growth-of-wordpress/

    Like this blog I'd like to just have a Facebook, Twitter, Press This button and then a More button for LinkedIn, Email, Print, Digg etc. If the answer to this second question is I have to create it myself don't know how to do so. Thanks!

    The blog I need help with is maneeshpangasa.wordpress.com.

  2. I just noticed another irregularity -- in sharing preferences have it set to show sharing buttons on all pages including my index page. However, it does not show the sharing button on my index page (unless I go in to edit one of my entries and make it so the entire entry is visible on the index page -- I don't have a short summary and then have to click the link to the post to read entire post) how can I make the sharing buttons appear on my index or homepage without making entire blog entries appear in their entirety on the homepage.

  3. Oddly the problem has gone away I can now see my +1 button again. Although sharing buttons still don't appear on my index page -- they appear on all other pages and my individual posts. If I make an entire post visible on my index page then I see sharing buttons on index. Weird I said to show sharing button on index page, all pages and posts -- for it to show on index entire posts must be visible from index page not short summaries of the post.

Topic Closed

This topic has been closed to new replies.

About this Topic