Need help? Check out our Support site, then


Gravitar not displaying on WP posts

  1. I've seen several threads posted on this site and others about missing (gr)avatars. I just set mine up this morning and it's yet to display on this site. I reviewed this post:
    http://onecoolsitebloggingtips.com/2010/01/24/gravatar-avatar-blavatar/

    On Users | My Public Profile, the Gravitar I set on Gravitar.com shows up perfectly.

    Then there's Settings | Discussion. There, under Avatars,

    Show Avatars is checked.
    Rating is G.

    Under Default Avatar, the radio for Identicon is checked. But it's not my avatar - it's the default image.

    Finally, when I visit Gravitar.com and see my profile, my image is clearly there. It's somehow not being linked.

    I read about things taking a certain amount of time to "kick in". Are we talking days?

    This isn't live & death but would like to get it working (or at least understand it).

  2. If you uploaded your avatar via the WP.com dashboard sometimes the up-loader acts quirky if you used the WP dashboard method I recommend heading over to Gravatar.com and delete the current photo then change the image name on your computer by one character (so the server doesn't call up the image waiting in que to be purged from the server) then re-upload the avatar image then wait a hour or two and see if your avatar is displaying correctly in this thread because the change usually happens here in the forums first.

    this useually fixes the issue when a person uploads their image through WP dashboard

    For future reference anytime I change may avatar I go straight over to Gravatar.com

    To change the image name on your computer you'll need to right click on the image then choose "Rename"

  3. I tried the things suggested by SL1K (e.g., deleted my avatar from my WP profile and uploaded a new one to Gravitar.com) but to no avail. Not sure if the problem is on Gravitar.com - they have no real support there.

    When I go to View my Profile, I see my avatar picture over on the right-hand panel (2 pics, in fact) but the large square in the center always displays only the blue Gravitar logo. Strange ... Click in once, and the intended avatar pic appears. It's as though it not being saved. At the bottom, I clicked http://gravatar.com/samadams1773
    but to no avail. Something's not hooked up.

  4. @samadams1773

    I can see the avatar image is showing on Gravatar so I am going to suggest you contact staff since there is probably nothing more that the volunteer's can do on their end to fix the issue for you...

    You'll need to click the I didn't find my answer button twice to open up the contact form PLease note staff is backed up so it could take a little while for staff to reply back they also recommend checking your spam folder via email client as well because some times their ticket replies get caught up by the email clients spam filter...

    here is the contact link http://support.wordpress.com/contact

  5. @sl1k
    Do you think that the Recent Update to Commenting changes are a factor re: delayed ie. cached gravatar image display? From the gravatar site FAQs:

    We cache your gravatars for periods of time, which means that your new gravatar will take effect after the old one expires from the cache. The reason we do this is to be able to serve your (and indeed everybody’s) gravatar images much more quickly and reliably. http://en.gravatar.com/site/faq/#answer-1-2

  6. @timethief

    Good point I didn't think of that Scenario it's most likely the issue at hand I'll modlook the thread for staff so they can check and see if it's cache or bug issue

  7. @SL1K
    http://support.wordpress.com/contact

    They are not accepting any support requests on this page. I would help myself if I knew how. Oh well ...

  8. @
    From the gravatar Help page:

    OK, but how do I contact support?
    Send an e-mail to support (at) gravatar (dot) com
    http://en.gravatar.com/site/faq/#answer-1-9

    Also note that WordPress.com Support Staff are accepting support tickets, however, one has to click the "I didn't find the right answer button" and if required the "I still didn't find the right answer button" so the form opens up. http://en.support.wordpress.com/contact/
    http://en.support.wordpress.com/contact/

  9. @sl1k
    Thank you for flagging this thread for Staff attention.

  10. Regarding your comment at http://onecoolsitebloggingtips.com/2010/01/24/gravatar-avatar-blavatar/ Gravatar display has disabled there by the blogger, so your Gravatar will never appear there.

    As for your gravatar here, it looks like the email isn't matching in your Gravatar account because it's not lower-case. This should have been done automatically for you, so I'd love to know where you initially entered your email address so we can get that fixed in the future.

    For now, just make sure that your email address is all lower-case at both Users -> Personal Settings in your blog's Dashboard and your settings at Gravatar.

  11. @macmanx
    I was just about to post that. :)

  12. :) I figured.

  13. As to Timethief:
    "one has to click the "I didn't find the right answer button" and if required the "I still didn't find the right answer button" so the form opens up."

    I've seen that before but I'm trying to tell you: they're NOT displaying that option. They've shut down inquiries !!! It ain't happening.

    Deep breath.

    I went back to Gravitar.com and studied My Account options, etc. I've stared at this many times. This time I stumbled onto Add an EMail Address. It never occurred me to go there because I was it was never demanded as a task - at least the way I had looked at it. Anyhow, I went in there and "added" the address I presumed it already had. It sent me a confirmation e-mail which I acknowledged, etc. This time, when I went back to View My Profile, my avitar was displayed in the center square (replacing the default ). We may be getting somewhere ...

    If this proves to be success, my comment back to Gravitar.com is to make the necessary step of "adding an e-mail" address much more obvious. As it is, it's just sitting there like "something to do" ...

    Can I get an amen?

  14. Well, as we all can see, success at last! I guess all's well that ends well, right?
    Thanks to Timethief & MacManx for their time & assistance.

  15. You're welcome!

  16. You're welcome from me too :)

Topic Closed

This topic has been closed to new replies.

About this Topic