Need help? Check out our Support site, then


Having current post at the top.

  1. So looks like I still need a bit more help. I have 2 posts created. But the newer post is at the bottom under the first post. I cannot find where a setting can be changed to put the newest post at the top of the blog.

    Thank you so much!

    The blog I need help with is lovescooking.wordpress.com.

  2. Did you make a post "sticky"? If so then your have created this and can edit the post and remove the "sticky" option. . See > http://en.support.wordpress.com/posts/post-visibility/#sticky-posts

  3. What I see is two posts with the same date February 27, 2010. All posts are displayed in accord with their date/timestamps. Have you set up the correct timezone for your blog here? > Settings > General? If you don't then your blog will remain on UTC time (Greenwich mean time) and the posts will display in accord with the date/timestamps in accord with UTC time.

  4. Since they both have the same date, you must change the time stamp (post editor > Publish module: click Edit, change time, click OK, cick Update Post).

    What you're experiencing happened because your first post isn't a newly published one: you just edited the pre-made "Hello World" post, which doesn't take your timezone settings into account.

  5. Ok just went back and looked. It's not a sticky note. And the time zones only show UTC as an option. For me being in S. Calif it's UTC -8 which I did have selected.

    When I did the second post about $10 a day, I clicked on Add New Post, which I assumed would be up at the top. I so wish I knew more about this stuff :D

  6. Just edit the time as Panos described.
    Go to edit your post and in the publish module edit the times of your posts.

    click the edit button:
    Published on: Feb 27, 2010 @ 14:52 Edit
    remember to update your post.

  7. "More about this stuff":

    a) If your first post was as a sticky, it would have a grey background.

    b) Your second post was published under UTC -8, but the first was the pre-made "Hello World" post, published under UTC 0: so, according to their current timestamps, the first post is newer. You should check their timestamps in the post editor and change the one of the two to correct the situation. (Or you can forget the timestamps and turn the date of the second post to Feb 28.)

    c) You have changed the title of the first post, but its slug (see here: http://en.support.wordpress.com/posts/post-title-url/ ) is still "hello-world". You should edit the post so that the slug reflects the actual post title (post editor: below the title box you can see the "Permalink"; click Edit, change slug, click OK, click Update Post).

    d) You would have avoided all that if you had deleted the sample post and created two new posts instead of producing your first one by editing the sample.

Topic Closed

This topic has been closed to new replies.

About this Topic