Need help? Check out our Support site, then


Header not displaying on mobile browser (iPhone)

  1. omarkalifornia
    Member

    I am currently using the Bueno theme and up until about 2 weeks ago, when I changed to the Elegant Grunge theme (back on Bueno now), I have not been able to see the header image on my iPhone Safari browser. I've cleared my cache, asked other friends to view it on their iphone and the header is not there, only a blog title with a gray background. The header was displayed like on my blog, but of course on a smaller scale.

    Has there been an update where headers will no longer be displayed on mobile browsers, the Bueno theme, or iphone safari specifically?

    I searched and came across the topic linked below; I've gone through the settings the original poster mentioned, but I still don't have a header to display. I do not want to switch back and forth to different themes to see if one displays the header, I would like to keep my Bueno theme.
    http://en.forums.wordpress.com/topic/header-image-viewed-on-iphone?replies=5#post-458799

    Thank you for your input.

    The blog I need help with is cervezaplease.wordpress.com.

  2. Go to appearance > extras and make sure that "Display a mobile theme when this blog is viewed with a mobile browser" is selected. Make sure and click "save" when done.

  3. omarkalifornia
    Member

    thesacredpath, I've made sure this option is enabled and even unchecked it, saved, let a few minutes pass, come back and enable/save, and nada. I also visited a friends blog who is using the same theme and also had a header, it's gone on hers as well.

    I'm starting to think it might have something to do with BraveNewCode, the site providing the mobile browser theme. I remember seeing messages that mentioned the theme could not be displayed, but a version provided by their end was being used; if they updated something on their end this might have disabled the header.

  4. @omarkalifornia
    Perhaps we Volunteers and Staff could be more helpful if we could lay eyes on the blog your are referring to. Your wordpress.com username is linked to your Twitter account. Here’s how to link your username to your blog in your blog Dashboard -> Users -> Personal Settings -> then scroll down to Account Details. Then scroll down to where it says ‘Website‘ and fill in the the complete URL for your wordpress.com blog starting with http:// and then save changes.

  5. omarkalifornia
    Member

    Sorry, here is the link to my blog. http://cervezaplease.wordpress.com/

  6. Thanks for posting the link to the blog in question. Hopefully either another Volunteer or Staff will have an answer for you. Or perhaps there will be an answer found at the iPhone forum. http://iphone.forums.wordpress.org/

  7. omarkalifornia
    Member

    I paid the iphone forum a visit, but the help there is for the App on either ipad or iphone.

    Hopefully someone comes along with suggestions.

    Thanks timethief!

  8. What is the link to the blog you are talking about. Your username is linked to twitter which does us no good.

  9. omarkalifornia
    Member

    Four comments above there is a link to it.

  10. D'oh. Sorry. I'm afraid that this is probably something staff is going to have to address. I don't have an iPhone (waiting on Verizon to get it) so I can't check or do any investigation.

    I'll tag this thread for staff attention, but you might have to wait till Monday and contact theme directly on this.

    http://en.support.wordpress.com/contact/

  11. Actually someone has already tagged it for staff attention I see.

  12. ~~TSP
    That would have been me. ;)

  13. Your site loads incredibly slowly on my wireless internet service. Check all your images. I found a few that were larger in file size than is recommended for the web. In general, images should not exceed 75k in file size, and if you have lots of images, I would even suggest 50k.

    Also, try going to appearance > extras and turn off the snow. That seemed to hang up Firefox considerably while the site was trying to load on my computer.

  14. Hi TT, I figured it was you.

  15. omarkalifornia
    Member

    Thanks for your help; will wait on additional staff help or contact directly on link above.

    PS
    I've removed the snow and at the site now loads quicker. Thx for the info on the recommended image size.

  16. omarkalifornia
    Member

    As for the header, I wish I had a screen shot of it but i deleted off phone. I pointed it out to a friend who has the same theme and she's having the same issue. I think this has something to do with the company providing the mobile look for the iPhone, bravenewcode.

  17. You're welcome. I was kind of hoping that either the snow, or possibly the page load times was what was causing the issue.

  18. omarkalifornia
    Member

    I found a blog that is using the Bueno theme and is currently displaying the header on the iPhone safari browser.

    First link is my site.

    http://twitpic.com/3mav28
    http://twitpic.com/3mav27

    Hope the images help.

  19. You know, on yours, I'm still seeing the little spinning pinwheel thing at the top right of the screen. Did you let the site fully load?

  20. The main thing I can see is that on the other site, there is virtually nothing except for the hello world post.

    Go to settings > reading on your blog and set your blog to display only 1 post per page and then check it and see what happens. If fact, publish a temporary very short test post. that you can then delete after checking your site.

  21. omarkalifornia
    Member

    I'll try that and report what I found.

  22. omarkalifornia
    Member

    Yes I'm letting it fully load, but when I took screenshot it was still loading.

    I've done as you suggested' went from full site to mobile, cleared cache just in case, but still no go.

  23. Well then, you will have to contact staff directly on Monday I'm afraid. I'm out of ideas.

  24. omarkalifornia
    Member

    Thanks for your time and help!

    If we figure it out, I'll post the answer.

  25. @omarkalifornia,

    I went to take a look at your site settings at Appearance > Extras and "Display a mobile theme when this blog is viewed with a mobile browser" was enabled. I turned it off and now I am able to see your blog header from my iPhone's Safari browser.
    What happens if you access the header image from this link using your iPhone browser?

    http://cervezaplease.files.wordpress.com/2010/06/cropped-beerbannermaxk22.jpg

  26. omarkalifornia
    Member

    naokomc, thank you for your reply.

    The option was selected so as to not load the full page when viewed from a mobile browser. I just want to be clear, I want the mobile theme on and to show the header while in mobile view. The issue wasn't that I couldn't get to my header image link, but rather that the header image is not shown while in mobile view.

    Take a look at both links below, they help explain further what I describe above.

    http://twitpic.com/3mav28
    http://twitpic.com/3mav27

  27. I'm having the same issue with the Greenery theme. I am curious if you ever received a resolution to your problem that you would be willing to share.

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic