Need help? Check out our Support site, then


HELP! Confused about gallery and unattached images in media library!!!!!!!!!!!!!

  1. Do not understand why when inserting media and choosing create a gallery, when putting multiple images into a post from the media library, why those images that were inserted into the posts via this way, show up as unattached in the media library. My whole point of doing it this way, was to do it in sections that I upload into the media library, and then check the unattached to make sure I put all the images into the posts where they belong, and then upload the next batch of images into the media library. If there are unattached images residing in there that were already put into galleries, it's going to be a nightmare to sort through and figure out if I've got all my images into posts. I looked online and saw a similar complaint as mine, but not a clear answer. I thought attached images in the media library reflect ones that are in posts, and unattached are images that were uploaded into media library and not used yet in a post. PLEASE someone out there give me a simple clear answer. Thanks!

    The blog I need help with is ardenfoto.wordpress.com.

  2. If you want to make sure that your images are "attached," then rather than upload them directly to your Media Library, upload them via the "Add Media" button to the post or page where you want them to appear.

    With the way that the Gallery feature now works (since November 2012), you can insert in a Gallery any image that appears in the Media Library regardless of where it was uploaded, meaning the same image can appear a number of times in any number of Galleries.

    Hope that helps.

Topic Closed

This topic has been closed to new replies.

About this Topic