Need help? Check out our Support site, then


help--I killed my home page!

  1. I am new at this so forgive the novice question;

    I was copying pages to get rid of the comments function and then deleting the old pages. Unfortunately I also deleted whichever page my Home page was tied to and now am getting the "well this is embarrassing" bit. All my other pages are fine.

    I think it has something to do with the fact that I chose to tie the home page to static posts but I cant find my way back to that page either...

    this is my url;

    http://thebalancedbeast.com/

    Thanks in advance for the help.

    The blog I need help with is whattheagility.wordpress.com.

  2. Just make a new Post of some sort and the message will go away

    New Posts are made the same place you deleted the original Hello World Post

  3. Do you have any blog Posts? You can set what page your site opens on under Settings->Reading. If you set the site to open on your blog posts and you only have pages, this is what you see; the solution is to pick another Page or to make some posts.

  4. I already tried the posts and it didnt work--is it because I tied it to a static page instead?

  5. They do have a couple of test posts so my just make a post is not the answer - but it is the default home page it looks like - so @RC - looks like your idea might be better

  6. Go to > Settings > Reading and tell us exactly what you see there:
    Front page displays
    __ Your latest posts

    A static page (select below)
    Front page:
    Posts page:

    refer to > http://en.support.wordpress.com/pages/front-page/

  7. Are you using a Custom Menu? If so, don't.

  8. Fixed--thanks everyone!

    I just went to what timethief suggested and chose the page I wanted as my main static page.

    Got it--thanks again!!!

Topic Closed

This topic has been closed to new replies.

About this Topic