Need help? Check out our Support site, then


Help with google verification

  1. carolinegriffin
    Member

    I have tried to verify my blog with Google and get this message - "We've detected that your 404 (file not found) error page returns a status of 200 (Success) in the header."

    I've searched around and think I need to try to change something on the web server - which I relly don't understand.

    Can anyone help?

    thanks

    Caroline
    http://www.carolinegriffin.com

  2. carolinegriffin
    Member

    Yes, exactly. (I have now hidden the page but it is still there)

    C

  3. If you followed the instructions to the point Google will find your site alright. However, you need to make the page public every week or so (depending on how often Google crawls your site) to keep the verification alive.

  4. carolinegriffin
    Member

    Thanks but google still says it can't verify the site. Unless it's just a case of waiting?

    I have looked on Google's help page and it has information about what to do if you get the error message I get - I just don't understand how to do it.

    Your site doesn't return a 4xx HTML status code for non-existing URLs

    If you're using HTML verification, it's important that a non-existing URL returns a 4xx status code. We can't verify sites configured to return other status codes (such as 2xx or 5xx) for non-existing URLs, because this would enable anyone to verify ownership of your site. You can try our meta tag verification method or change your server's configuration.

    This configuration presents a security risk for site verification and therefore, we can't verify your site. If your web server is configured to return a status of 200 (found) in the header of 404 (not found) pages, and we enabled you to verify your site with this configuration, others would be able to take advantage of this and verify your site as well. To ensure that no one can take advantage of this configuration to view statistics to sites they don't own, we only verify sites that return a status of 404 in the header of 404 pages.

    If your server is configured to return something other than a 404 for non-existent pages, try our meta tag verification method or change your server's configuration.

    You can change your web server configuration to return a status of 404 in the header of 404 pages and still provide a custom error page (see Apache information and IIS information). Once your web server is configured correctly, try to verify the site again and we'll recheck your configuration.

    Caroline

  5. Well, I never had any problems verifying my wordpress.com blog with Google, and I never had to wait.
    Manage > Write Page. In the page title field I write google4f645e3adsdaa48g3a41z.htmlor whatever I am supposed to write. I publish that page. Then I have a page called google4f645e3adsdaa48g3a41z.html (On your blog you should have a page tab titled google4f645e3adsdaa48g3a41z.html). Then I verify with Google. OK. Then I set the page to private.

  6. carolinegriffin
    Member

    Thanks - that's exactly what I've done but I'm still getting the same error message. How frustrating! thanks for trying to help, I appreciate it!

    Caroline

  7. sensuouscurmudgeon
    Member

    There's no need to make the Google-recognition page hidden and then make it public from time to time. What I did was to post it as a regular post (not a page), but I set its publication date to several months earlier. That way none of my regular readers ever saw that post, yet it's always there for Google to see.

  8. @carolinegriffin-I'm not sure what you mean by "hidden", but if your readers can't see it, neither can Googlebot.

    I made mine a Parent (top level) Page, clicked on the verification button in Google's Webmaster Tools to verify it with Google and then made it a Child Page of the About page so that it didn't show up in the Navbar on my blog. The verification page still shows up in the Pages Widget, which I have conveniently put at the very bottom of the widgets in my sidebar as it's easier to get "back to the top" level pages and is still visible as a link for Googlebot.

  9. I put mine in a page and just excluded the page from the pages widget.

  10. @vivian-completely forgot that you could do that. (insert sound of hand smacking forehead here) I just excluded it from my Pages widget and will be curious to see if Google still verifies it on the next crawl. (BTW-Love, love, love your site redesign!)

    Also, now that WordPress.com has given us all sitemaps, you can add a sitemap to your google webmaster tools. When the box comes up to enter the sitemap address, just add "sitemap.xml" (without the quotes)

  11. jennifer - re: the site design - thanks! And I forgot about the sitemap thing. I need to head over and put that in there.

  12. I had this same issue and realized SO many others did as well. The FAQ page gives good information for Google verification, but a few tips could be added. (Searching the forums gave mixed results, as seen above). I'll give you the "what worked for me" below, and it's also posted on my site: No, Really. How Do I Verify My Site With Google?

    1. Make sure your site is NOT set to Private. Go to Settings, Privacy and tick the first option.

    2. Be sure the page (not post) you created is NOT set to Private ("Keep this post private"). Ensure your "Publish Status" is set to Unpublished (draft status).

    3. Don't publish your page. Instead of clicking Click to publish your Page, simply click Save.

    So now you should have a verifiable page that won't be shown to the public anywhere or for any reason.

    I hope this helps someone. I was in the same boat just days ago.

  13. Setting the page to private BEFORE Google has verified it is probably your mistake. Make it public until you can confirm that Google got it.

  14. /nod to rain

    If it is private, Google will not crawl it, and if you just leave it unpublished as a draft as elledoesit suggests, same thing; Google will not crawl it.

  15. => Google did not touch it until I changed the settings. Verification on my other sites outside of WP has always gone nice and smooth.. quite fast too. None of the other suggestions seemed to 'stick', but finally one did. Hopefully someone else will get the same benefit. After all, a single click can revert any of the settings if something is amiss. Hopefully the FAQ can be clarified to help save people hours of trial and error.

  16. carolinegriffin
    Member

    Thanks all,

    Just to be clear, I did leave the page up for several hours and still got the same result. I only hid the page once I realised the verificationw wasn't working and I needed some advice!

    Caroline

  17. Tip: Do not create a private page, but create a regular post instead. Enter the Google code you are given, e.g.
    google3e89b1b40332c634html
    in the title field. Set the publish date earlier than your first post. You post will then look like this, e.g. http://tpvswp.wordpress.com/2007/09/19/google3e89b1b40332c634html/
    Works!

  18. I created a page with the title of the file given me by google to verify (and I put it in the body, too). The verify went through. But I'm not excluding it right on the pages widget as Vivian said to do. I'm pasting the address of the page in the exclude dialogue box, but it's not excluding it (unless it takes a little time--that is, doesn't happen right away; that is sometimes the case, it seems, in WordPress--you think something didn't take, and then you come back, and it took. Or maybe it's leprachauns?

    Whazup?

  19. You have to exclude the page by using the page ID, not the title of the page. Here's how to find the page ID http://faq.wordpress.com/2008/05/29/how-to-find-page-id-numbers/

  20. Vivian, I did this, and it worked! So I guess now I'll be regularly verified by google without having to do anything more. Yea! Not that I have a clue what it means....

    I wonder if Caroline got verified. Caroline, report back, did you make it work, or not?

  21. carolinegriffin
    Member

    Unfortunately not! My problem doesn't seem to be to do with posting up the verification code, but something to do with this message -

    "We've detected that your 404 (file not found) error page returns a status of 200 (Success) in the header."

    I'm still hoping to find an answer - so any thoughts are welcome!

  22. I'm in the same situation. Any help?

  23. Ok, caroline, please... recheck the url you enter in the google webmasterl tools, please.
    My problem was:
    My url was is orensbruli.wordpress.com but in google I had entered orensbuli.wordpress.com.
    I hope this help to you (notify me, please).

  24. carolinegriffin
    Member

    I had a few days off from trying because i was so frustrated, but now I'm having another go. I'm going to leave the post up for a couple of days and see if that helps.

    C

  25. I got the same error caroline and my 404 page does not work it just sends me back to my home page, any help?

  26. I found this Caroline:

    Your site doesn't return a 4xx HTML status code for non-existing URLs

    If you're using HTML verification, it's important that a non-existing URL returns a 4xx status code. We can't verify sites configured to return other status codes (such as 2xx or 5xx) for non-existing URLs, because this would enable anyone to verify ownership of your site. You can try our meta tag verification method or change your server's configuration.

    This configuration presents a security risk for site verification and therefore, we can't verify your site. If your web server is configured to return a status of 200 (found) in the header of 404 (not found) pages, and we enabled you to verify your site with this configuration, others would be able to take advantage of this and verify your site as well. To ensure that no one can take advantage of this configuration to view statistics to sites they don't own, we only verify sites that return a status of 404 in the header of 404 pages.

    If your server is configured to return something other than a 404 for non-existent pages, try our meta tag verification method or change your server's configuration.

    You can change your web server configuration to return a status of 404 in the header of 404 pages and still provide a custom error page (see Apache information and IIS information). Once your web server is configured correctly, try to verify the site again and we'll recheck your configuration.

  27. carolinegriffin
    Member

    Thanks for this. It's really helpful. I got a message from WordPress support saying there is nothing that can be done in this circumstance. I don't think wordpress lets you change metatags so I can't verify in that way. I'll have a look at the apache and IIS routes.

    thanks again, I really appreciate your help

    caroline

  28. I had same problem as Caroline and I removed the page as private . .verified. . then made private

Topic Closed

This topic has been closed to new replies.

About this Topic