Need help? Check out our Support site, then


Here's how to add a Tweetmeme button to your blog posts. w/o plugins or long cod

  1. What exact code are you using on your blog? The button seems to work fine, and there's nothing wrong with your Twitter stream either. Please go to the post and copy the exact code, all of it, square brackets and all and paste it here.

  2. Are you seeing my twitter name in the tweet? That's the part I can't seem to get to work.

    Here's the code (between backticks) as currently in my posts:

    '[tweetmeme source="@RBCfocus" only_single=false]'

  3. The very first post says your code should be:

    [tweetmeme source=”your_twitter_name” only_single=false http://www.URL.com%5D

    You don't have the actual URL in there? Yours should look like

    Altogether, it looks like this: [tweetmeme source=”@RBCfocus” only_single=false http://customerdriven.wordpress.com/%5D

    But I'm also wondering: You say those are backticks you used?

    real backticks do this to code

    Those look to be single quotations. I'm thinking if maybe the problem is related to the quotation marks you're using, or if the theme itself is possibly messing them up by making them curly quotes or something. Please tell me you're not composing in Word, because that WILL cause these kinds of problems.

  4. you dont need the @

  5. I've gone back and added the URL and retyped the code straight into WP (it's possible I did cut and paste it from Word because I pasted it in a doc so I wouldn't forget it), but I still can't see any difference when I try to retweet. Should I be seeing it when I tweet myself?

    I'm using the double quotes key when I type (just like with other code in WP for colors, etc) - that is correct, isn't it? You were right about the single quotes io backticks in my post. I couldn't find the backtick key on my laptop...

    [tweetmeme source="@RBCfocus" only_single=false http://customerdriven.wordpress.com]

  6. THANK YOU, LOLAVIBE!!!!!!!!! That fixed it!

  7. yw lol

  8. Ah, you've got a better eye than I have! Thanks for picking that up.

  9. the [tweetmeme.......] doesnt work after 1st tweet... instead the tweetmeme website loads. help

  10. It does that because it's designed to only be used once by each Twitter account per post.

  11. I've been trying to insert the Tweetmeme button in the last few posts on my blog to no avail: http://www.poptartlondon.com

    The button appears when I'm logged into wordpress but not when I'm logged out i.e. no one else can see it. For instance, in my most recent post I'm using this code:

    [tweetmeme style="compact"; tweetmeme source="poptartlondon"; tweetmeme alias="http://bit.ly/coIfcg"]

    which I've retyped out numerous times (not from word or anywhere else). Does anyone know what the problem could be please? Any help gratefully received. Thank you.

  12. that doesnt look anything like the code suggested in the first post

  13. Ok. I've just tried [tweetmeme source="poptartlondon"] and it's still not working.

  14. when the official announcement and the documentation for this feature is coming ?

  15. @pahoxis
    Good question that only Staff can answer. Hopefully the announcement will be made soon and the support documentation for short codes will be updated to include the tweetmeme shortcode. http://en.support.wordpress.com/contact/

  16. I'm a little confused, TT can you help me out please?

    [tweetmeme source=”your_twitter_name” http://www.URL.com%5D

    Does the pernalink to my post go in http://www.URL.com%5D or if I want to add the meme
    to my blogs home page do I simply add the URL for my blog?
    I've read all the replies in the thread, but just want to be clear before I try to add it?
    Also would it be redundant to use the tweetmeme if I'm using GetSocial Live?
    Thanks?

    P.S. Do you need any special

  17. As a test I hit the retweet on my post, now instead of showing retweet it shows tweeted,
    will it appear as such to readers?

    Thanks....

  18. Now I'm noticing I added the code [tweetmeme source=”joer223” only_single=false] at the beginning of another post, and it say "tweeted" where it should say "retweet" Should the code only be added at the end of a post in order for it t show "retweet?

    Thanks....

  19. Dang! no matted where I put the code it's showing tweeted, on all posts...(scratches head)

  20. @joer223
    When you see Volunteers answering support questions but not answering yours then this is an indication we do not have a solution for you. We post only is we know we have correct answers to share. I do not use this shortcode. I cannot help.

    I have flagged the thread for Staff and requested that they include it among the shortcodes in support documentation shortcode and provide specific support documentation for this shortcode. It's month end at work. I am swamped. I do not have time to test this shortcode for you. I can do no more.

  21. @TiTI

    Ok......I'm sorry.

  22. It says "Tweeted" because you've tweeted it. You can only tweet each post once; to other people, who have not tweeted it yet, it says "Retweet". That is to stop greedy people from hitting the button over and over and over, ramping up the fake numbers.

    This is not a PROBLEM. This is how it's supposed to work.

  23. @raincoaster
    YAY! Thanks for the logical and sensible answer I should have clued into myself ... DUH I swear it does month end bookkeeping dumbs me down :(

  24. Thanks. I said much the same on the same page earlier, but I guess nobody reads that.

  25. My blog address is http://phoxis.wordpress.com and recently i have mapped my domain name http://phoxis.org with wordpress.com and using this as the primary address. The thing i notice that the linktweets from phoxis.wordpress.com seems to be lost, and those posts shows 0 tweets, although the checkbox beside Twitter in the publicize box is checked and inactive. what is the matter here, i am confused.

  26. ko ane ga bisa gan

  27. wilddogsandenglishmen
    Member

    I think I must be a numpty but I can't get this to work at all. I've gone into the html editor in my post, and added at the top of all the code the following:

    [tweetmeme source="tvustudent" only_single=false http://tvustudent.wordpress.com/2010/06/01/xanga-com-usability-evaluation/%5D

    And it it placing this into the post as text, it's not working.

    Am I missing something?

    Or am I meant to be putting this into a text widget in my sidebar rather than the html in the post code?

    I'd love some help on this as would love to add this feature to my blog posts - but I wish WordPress.com could just be a simple widget or box we could tick to add this to all posts, seems a bit bonkers it has to be this complicated when Twitter is a key way to drive traffic and promote WordPress.com blogs.

  28. You put it in the post, but are you putting it in via the Visual editor or the HTML editor? Whichever you're using, try the other one. Sometimes this depends on the theme, although staff was supposed to have fixed this.

  29. Thanks. This worked really well on mine.

    @wilddogsandenglishmen place it at the bottom of the post, use the Visual Editor, not the HTML editor. You can skip the double-quote on the username too. Hope it works for you.

  30. hi, i was stuck on the problem for such a long time! thanks to your solution, i can finally have that tweetmeme on my wordpress! Thanks alot!

Topic Closed

This topic has been closed to new replies.

About this Topic