Need help? Check out our Support site, then


Hi there. I can't embed youtube videos to my blog.

  1. Hi there. I can't embed youtube videos to my blog. I try to save as a draft, to publish it, and nothing happens. the video justo don't appear on the post. whtas going on?

    The blog I need help with is pequenosclassicosperdidos.wordpress.com.

  2. If you are not running one of the browsers and versions listed at http://browsehappy.com/ please try upgrading or switching first. If you are try clearing your browser’s cache: http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=32050

    The shortcodes work every time for me. It takes less than 30 seconds to post one.

    The video embeds that WordPress.com supports for all of our blogs - no upgrade required. http://en.support.wordpress.com/videos/

    Video shortcodes > http://en.support.wordpress.com/shortcodes/#video

    youtube shortcode http://en.support.wordpress.com/videos/youtube/

  3. I am having the same problem, but it just started today.
    I tried coming in from Chrome and Safari (my two usual WP browsers) and the result was the same; the code that I pasted in (and saved) for the YouTube link vaporized, and there was nothing where the code was. I repeated the experiment many times, across the three blogs I have on WordPress, and struck out every time. This must be a today sort of problem?

    http://katemckinnon.wordpress.com/

  4. Use the shortcode.

  5. Thanks- shortcode is working for me now, although it wasn't this morning. Things have been a little hinky for me on all of my WP blogs for about a week; a lot of "sorry, nothing here" messages when I click "Preview" for posts in progress (even after saving as a draft) and unusual lags in edits propagating. I figured that there was just some kind of work going on behind the scenes.

  6. We are looking into this, but if you have problems with the shortcode and the URL in the browser address bar, click on Share below the video and use the HTML link there in the shortcode. The Share HTML link has worked for me in my testing every time.

    The link from Share also seems to work fine with Insert Media from URL.

  7. Thak you all, now it's working with shortcodes.
    Thanx

  8. Thank you for reporting this!

    We researched the issue and found that YouTube had changed the format of their embed code, so we updated WordPress.com to work with the new formatting.

    Can you please try embedding a YouTube video again? An iframe embed code should get converted into a shortcode now, just like it used to.

    If you have any trouble, please reply back here and include the YouTube video link or iframe code you're using.

  9. Thanks for your quick response. Shortcode is great but limiting.

  10. myheartsathome
    Member

    I'm having this problem too :( Can't figure it out at all - I use the blog as part of an educationaly tool, so now assuming I'm going to have to find a different blogging platform.

    Very disheartening!

  11. myheartsathome
    Member

    figured out how to get the actual video over (with a LOT of fiddling around) but I can't get the version I usually get that leaves out the 'suggested videos' :/

  12. There is actually still a problem with the embeds- thanks for the adjustment, Happiness folks, but it's practically impossible to leave visual space AFTER the video embed now.

    Even manually doing it in HTML with an " " insert is overwritten unless it's uploaded verrry carefully, without leaving HTML mode.

    Can we fix this too? I hate things all run together visually.

  13. The above complaint (about the space after the video embed) seems to be theme-dependent. I can't get it to work in Chateau (which is a very hinky theme in general). Here is an example of a post in which I was able to manually force spaces twice, but if you scroll down to the final video, Bryan Ferry doing Chance Meeting, no HTML insert, no number of manual returns, NOTHING will force a space between the video and the text.

    Link:
    http://lovelettersbook.org/2013/06/30/introductions/

  14. myheartsathome
    Member

    I don't know if this will be any help to anyone, but I did a bit of a search and am now using this format which I place into the TEXT section:

    [youtube http://www.youtube.com/watch?v=uvMiz0-nPxs?rel=0?rel=0&hd=1]

    all I do now is just copy the letters/numbers of each youtube video and insert them into the above link (obviosuly replacing the previous letter/number combo) - I am not a technical person and kind of just made that solution up after reading something someone suggested - and it's working for me for now - a pain, but at least I don't need to start a whole new blog.

  15. I don't know if this will be any help to anyone, but I did a bit of a search and am now using this format which I place into the TEXT section: [youtube http://www.youtube.com/watch?v=uvMiz0-nPxs?rel=0?rel=0&hd=1%5D

    Mel, I was just about to ask you what code you were using before to try to add videos, but it looks like you've worked it out. Nice work! The option required to hide the related videos is also posted on our YouTube help page at http://en.support.wordpress.com/videos/youtube/#video-customization-options Look under the "Video Customization Options" section to find that option and more.

  16. The above complaint (about the space after the video embed) seems to be theme-dependent. I can't get it to work in Chateau (which is a very hinky theme in general).

    First, thank you for including an example page link!

    I reviewed http://lovelettersbook.org/2013/06/30/introductions/ and I don't think this is a problem with the YouTube video (which gets converted from an iframe to a shortcode automatically—it has always done that from the beginning on WordPress.com). It looks to me like the problem is a more general one because when I opened the post for editing, all the text ran together in my preview view. That indicates there may be a problem in the HTML earlier in the post or that something you copy and pasted from another source such as a web page, a different web editor, or maybe even a program like Word can have extra code in it that is not meant to be added to web pages and can cause formatting issues (this is just one possibility).

    Regarding formatting, check out this link for a little background: http://en.support.wordpress.com/microsoft-word/

    Regarding the video not having spacing under it, I tested adding videos using the Chateau theme on my own test blog and I found that embedding a video using the auto embed way where you just put a link to the video on its own line worked really well every time and I didn't see any spacing issues for YouTube videos that way. Whatever you were doing before (I'm not sure how your content got to be the way it is) seems to have some formatting issues because the shortcode is getting collapsed into the rest of the text. Another way around it would be to keep using the iframe-to-shortcode converter (or just a shortcode) and add "<p>" and "</p>" codes around the shortcode using the Text tab after the video has been added.

    I think the auto embed would be the simplest solution. Would you be wiling to give that a try? http://en.support.wordpress.com/videos/youtube/

  17. Please check the link again; my blog looks utterly normal to me (except for the missing space under the Ferry video)- you might have looked at it during a moment of updating.

    I am using auto embed, but I want a) to control the size of the video, and b) to have a space under it.

    Perhaps if you could look again, you would see what I mean. This forum is vastly hampered by not allowing screenshots, but if things really genuinely are run together for you, I need to see a shot of it, because that would be a rather serious matter.

  18. you might have looked at it during a moment of updating.

    I looked at it in the editor. When I opened the page for editing, all of the spacing collapsed. Here is an example: http://cl.ly/Q1P8

    I'm not sure why that is happening for me, but it doesn't happen when I test my own blog with content I have typed in directly.

    I am using auto embed, but I want a) to control the size of the video, and b) to have a space under it.

    You can do all of those things using the auto embed method. Can you please try a test?

    Go to https://lovelettersbook.wordpress.com/wp-admin/post.php?post=73&action=edit and replace this:

    [youtube=http://www.youtube.com/watch?v=UXvt7pbMsaI&w=560&h=315]

    With this:

    http://www.youtube.com/watch?v=UXvt7pbMsaI&w=400

    And then preview.

    When I do the same, the video size works and the spacing is fixed as well. I do think the spacing issue you're seeing is odd, but I also think it has to do somehow with just the content on that post and if you tried the following test on a new post, the spacing for the shortcode would work there as well. I tested this on my own text blog using Chateau and it also worked in my testing:

    This is a test to see if embedding a YouTube video in a blog using the Chateau theme has space after the video but before the next paragraph.
    
    [youtube=http://www.youtube.com/watch?v=UXvt7pbMsaI&w=560&h=315]
    
    If there is text in separate paragraphs surrounding a YouTube or auto embed link, spacing should get added below the video as long as it is rendered as a paragraph.
  19. Just a note; I did type all of my content in directly. Only the quotes were cut and pasted. I find Chateau to be a VERY hinky theme.

    It's beautiful, but it's a pain in the butt. I know that premium themes are more functional, but the free ones should work too.

    I have two other WP blogs that I have zero trouble with, each of them has a different theme and neither of them have a WP-hosted URL (which apparently requires my enabling third party cookies over my entire Chrome experience to enjoy the Preview or login features on the blog).

    So... it's hard for me to really know which is my biggest problem- the third party situation, or the Chateau theme.

  20. If you are finding any specific problems with Chateau or want to post feedback about it, the best place to do that is at http://en.forums.wordpress.com/forum/themes/ Make sure to include a specific example of what's going wrong and post separately for each issue. The theme team is great at reviewing and they can let you know if the issues you're finding are really something related to the theme or not and whether they can be addressed.

  21. Hello,
    do embed YouTube onto a WordPress blog, make sure the link begins with http:// not https://
    If this still doesn't work, please reply!

  22. Hello
    Yes I made sure it begins with http:// not https://
    And still it says the video player is too small.
    Anyone help?

  23. Hi thank you but that does not work.

  24. try to put only youtube video link like text in your post :)
    http://duoinet.wordpress.com

Topic Closed

This topic has been closed to new replies.

About this Topic