Need help? Check out our Support site, then


Hide 2nd Home page link from Navigation Menu

  1. I'm using the Twenty Ten theme - it displays a 'Home' link even when no other pages exist. I created a static page called Home, added content, added the page to my Menu, trashed the default Home from the menu & dragged 'my' homepage into it's place. But the default page is the one that remains visible on my site - I have to open Home on the menu to see my content.

    I've found an explanation - I now have two links going to the same location, & am advised to do this: "If the theme you’re using doesn’t display child pages in the pages menu, you can hide the second link by editing the page and setting another page as the Parent in the Attributes module" as the solution." But since I trashed that page I can't edit it. My new page has only the '(no parent)' option, no 'Main Page (no parent)'.

    Please help?
    Belinda

  2. Exactly which theme are you using? Does it have the custom menu feature? If so then have you considered creating a custom menu and including only the pages in it you want to include?

    1. You create a custom menu. http://en.support.wordpress.com/menus/

    2. You add the Parent pages you want to display and arrange them in the order you want.

    3. Then you add and drop and drag the subpages below the appropriate Parent pages, and when you have everything arranged in the menu that you want you save the menu.

    4. Go to the “theme location” module at upper left on the menu page. Select your custom menu name from the pulldown labeled “primary location.” Click the save button in that module.

    5. Refresh your browser so that it isn’t possibly pulling a cached page, and view see your new menu with Parent pages and dropdowns to sub-pages.

Topic Closed

This topic has been closed to new replies.

About this Topic