Need help? Check out our Support site, then


Home Page Doesn't Load After Logging In

  1. Actually, this affects my whole WordPress experience. I am having trouble loading anything on the page that comes up after logging in. The tabs I'm having trouble loading are: New Post, Freshly Pressed, Reader, Settings, Help, and My Blogs. The only tab that works is Stats. All that comes up is the white background and nothing more. I know it has nothing to do with my browser, because I have the most up-to-date one (IE9).

    It has been like this for three days. I made a complaint earlier this morning, but no one ever got back to me. Please help fix this problem. Thank you for your time.

  2. Hi there,
    Are you logging in using the secure https:// log-in? see http://en.support.wordpress.com/https/

    Have you tried running your browser with all extensions and add-ons disabled?

    Do you have another browser you can try like Firefox? If you are willing to try using it and don't have it installed click here please http://browsehappy.com

  3. I'm having exactly the same problem, have tried the above except for Firefox and still not working

  4. Do you have the Adblock Plus add-on installed in Firefox? If so, disable it, restart Firefox and then try again. Adblock Plus has been doing all sorts of mischief at wordpress.com lately.

  5. I'm on internet explorer and have the same problem. I get a bar at the top which says ,'To protect your security, Internet Explorer has blocked this websire from displaying content with security certificate errors. Even if I click allow, it still wont work. I've also cleared the cookies and temporary internet files etc. Help!!!!!!

  6. same here. can't see my stats, see/manage my blogs etc

  7. I have been having this same problem for nearly a week. Nothing on the Home Page works. Very very frustrating.

  8. @annarashbrook
    @craftyjulia
    @caseythompson

    Please answer what follows:
    Exactly which browser and version of it are you using please? If you don't know click here to find out http://whatsmyuseragent.com/

    How are you connecting to the internet and to WordPress.com. The way you connect to the internet (mobile, satellite, DSL, dial-up) and to your blog, and how many proxy server jumps etc. it takes to connect can cause problems. There maybe be problems with your ISP and/or with the proxy servers. Also note that the main dashboard isn’t designed to work with touch devices through the tablet and smartphone browsers.

    Are you logging in on the WordPress.com home page or are you logging in directly to your own blog?

    Are you logging in using the secure https:// log-in? see http://en.support.wordpress.com/https/

    Have you tried running your browser with all extensions and add-ons disabled, inluding any AdBlockers?

    Do you have another browser you can try like Firefox? If you are willing to try using it and don't have it installed click here please http://browsehappy.com

  9. 1) internet explorer - 8
    2) highspeed cable
    3) either
    4) yes
    5) no
    6) great idea, let me try, and thanks for your help!

  10. 1. Internet explorer 8
    2. Broadband wireless in Austria
    3. Logging onto secure homepage, as I've cancalled all the extnesions and add-ons and goen through clicking on the bar that appears and follwing the microsoft page to cancel it and its effects.
    Is firefox any better, I tried it once and I didnt like it.

    Surely there must be someway of complaining to microsoft about this security certifcate message?

    I'm aboout to give up, I get most of my blogs but not all by email, but still would like to access my stats!

  11. 1) Internet Explorer 9
    2) Sometimes (high-speed) cable, sometimes Wi-Fi
    3) WordPress.com home page
    4) Sometimes
    5) No, but why is it necessary to do that?
    6) I have never used Firefox, nor Google Chrome. I wish to use only Internet Explorer.

    New developments:
    Still can't see anything from what my first complaint says above. I also can't see the graphs of the Stats. I can't switch the stats view from one blog to the other from that page. I have to hover over my username, hover over the blog, and then click "Site Stats."

    I can't see my notifications without having to be looking at one of my blogs (doesn't work on home page). It keeps saying my browser is out-dated, yet I have the most-up-to-date Internet Explorer.

  12. Is anything being done to help fix this? It's been about a week since I first noticed this.

  13. @annarashbrook
    @craftyjulia
    @fairydancer221

    Thanks for providing details. It appears what you have inb common is IE browers. I have flagged this thread for Staff attention. If you are willing to try using Firefox and don't have it installed click here please http://browsehappy.com

  14. Are you folks able to update to IE 9? If not, would you please give it a try in Firefox or Chrome?

    http://browsehappy.com/

  15. I downloaded firefox and it works great now!!!!
    thanks timethief!

  16. This is the same problem I reported last night, also been going on about a week, I tried all of the suggestions and nothing worked. "The tabs I'm having trouble with are New Post, Freshly Pressed, Reader, Settings, Help, My Blogs. The only tab that works is Stats". Ditto. I also have E9. Can't install Firefox or Chrome because I use a residential computer lab and computers go into some deep sleep mode every night at midnight putting everything back the way it was. Checked with the computer lab gurus here and they say they've changed nothing lately. I go to WordPress.com 1st and then log in from the Freshly Pressed page.

  17. It wasn't working properly with IE8 and it's not working with IE9. I'm still holding off on downloading Firefox, because I have faith that the WordPress.com staff can fix this. I've seen it work on only one other computer with IE9 (5 days ago), so I have hope.

  18. Updates:
    I can now see the Notifications on the home page, but it still keeps saying my browser is outdated.

    I can also see the graph on the stats page. I can also look at the stats from each blog with out having to do all of those steps.

    Thanks for fixing these. There are still the other issues with the home page, but these fixes are good.

  19. fairydancer221, are you running IE 9 in compatibility mode? If so, IE 9 will report itself as IE 7.

    Please try disabling compatibility mode, as it uses IE 7's rendering habits, which we no longer support.

  20. I didn't realize my browser was in compatibility mode. Thank you, macmanx. I turned it off and everything is working again.

  21. You're welcome!

  22. Hey WordPress people, something's happened, I can access everything except reading my blogs, I can read the list of them but not the new posts! Am improvement! Now how do I return my computer to remembering my passwords so I dont have to log into everything each time?

  23. I turned off Compatibility View and it also completely solved the problem. Thank you macmanx.

Topic Closed

This topic has been closed to new replies.

About this Topic