Need help? Check out our Support site, then


How can disable the leave a comment box in my home page?

  1. Hello, I would like to disable the leave a comment box in my home page and put in my Posts page. But it wont let me. Can you help?

    The blog I need help with is black1011.wordpress.com.

  2. thistimethisspace
    Member

    You have only two choices. You can leave you blog in it's conventional structure whereby the front page by default is where all your published posts appear. Or you can create a static front page.

    There is only one page in a blog for posts. The front page of the blog by default will display your posts (not pages) http://en.support.wordpress.com/post-vs-page/ in reverse chronological order, with the most recently published post on top.

    If you do not want all the posts to show on the front page, then you can create two pages ie. a static front page example “Welcome” for your site and a “Blog” page for posts.
    http://en.support.wordpress.com/pages/#create-a-new-page

    After you do that you go to > Settings > Reading and make the designation change and click “save changes”.
    http://en.support.wordpress.com/pages/front-page/

    Front page displays
    _Your latest posts
    _A static page (select below)
    Front page:
    Posts page:

  3. thistimethisspace
    Member

    This page > Settings > Discussion
    Discussion settings is where you set up defaults for comments.
    http://en.support.wordpress.com/settings/discussion-settings/

    We can also override the default settings and enable or disable future comments on any individual post or page.
    http://en.support.wordpress.com/enable-disable-comments/

    Note 1: By default, new blogs on WordPress.com will have the Discussion hidden. You can reveal it by clicking on Screen Options http://en.support.wordpress.com/screen-options/ on the top right corner of your Admin page, and checking the box that says Discussion so the module is included. http://en.support.wordpress.com/modules/#list-of-modules

    Note 2: To disable comments on already-published posts or pages, you can edit each post and uncheck the "Allow comments" setting. See http://en.support.wordpress.com/enable-disable-comments/#enabledisable-comments

    To disable comments on already published pages, you go to Pages > All Pages, click the little square to select all the pages, select "Edit" from the Bulk Actions pulldown, click Apply, select "Do not allow" from the Comments pulldown, click Update. Same thing for already published posts, in Posts > All Posts.

  4. I did create a static page but the leave a comment box is still there. Is there just no way to take it off. Is there an option to disable it from a certain page and not others.

  5. Fastest way: you go to Pages > All Pages, hover over the page title, click Quick Edit, uncheck the option "Allow Comments ", click Update.

Topic Closed

This topic has been closed to new replies.

About this Topic