Need help? Check out our Support site, then


How can I customize my meta description and display on Google results?

  1. When I "Google" my blog, it is displayed as "RSS" instead of "livelybone" or "www.livelybone.com". How do I change the display settings for search engines? Also, the description of my site is showing up as the name files of the photos on my latest post. How do I set up a meta description?

    The blog I need help with is livelybone.com.

  2. Hi there - please add "lively bone" as your Site Title and add a descriptive Tagline under Settings > General:

    https://livelybone.wordpress.com/wp-admin/options-general.php

    That will help Google index your site properly.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.