Need help? Check out our Support site, then


How can I hide comment boxes

  1. cyclingtynedale
    Member

    I have set up a small blog which is being reviewed before going live with a url to be purchased. However some of my pages are showing a leave a comment box at the bottom and others are not despite setting up all pages in the same way. How can I stop this happening as I have used the same default settings for all pages created?

    The blog I need help with is cyclingtynedale.wordpress.com.

  2. This page > Settings > Discussion
    Discussion settings is where you set up defaults for comments.
    http://en.support.wordpress.com/settings/discussion-settings/

    We can also override the default settings and enable or disable future comments on any individual post or page.
    http://en.support.wordpress.com/enable-disable-comments/

    Note 1: By default, new blogs on WordPress.com will have the Discussion hidden. You can reveal it by clicking on Screen Options http://en.support.wordpress.com/screen-options/ on the top right corner of your Admin page, and checking the box that says Discussion so the module is included. http://en.support.wordpress.com/modules/#list-of-modules

    Note 2: To disable comments on already-published posts or pages, you can edit each post and uncheck the "Allow comments" setting. See http://en.support.wordpress.com/enable-disable-comments/#enabledisable-comments

    Quoting justpi: To disable comments on already published pages, you go to Pages > All Pages, click the little square to select all the pages, select "Edit" from the Bulk Actions pulldown, click Apply, select "Do not allow" from the Comments pulldown, click Update. Same thing for already published posts, in Posts > All Posts.

  3. cyclingtynedale
    Member

    Thank you - seem to have solved the problem with your help.

Topic Closed

This topic has been closed to new replies.

About this Topic