Need help? Check out our Support site, then


How do I disable any reply or comments on my blog. I have tried everything.

  1. I don't want any reply box or comments on my blog. I followed the directions in the discussion section of the blog. I unchecked all the boxes but I still have comments and reply boxes on my pages and posts. I want to disable all comments and reply boxes.

    The blog I need help with is rethinkingyourchristianity.wordpress.com.

  2. I am encountering the same problem.

    According to wordpress's instruction on http://en.support.wordpress.com/enable-disable-comments/, by unchecking the box of Allow Comments, the function will be enabled. However, this option (Allow Comments) doesn't exist in the Setting- Discussion of my wordpress.

    I would like to disable the function of leave a reply function at the end of each page. How can I do that? ANy help would be very much appreciated. Thank you.

  3. go to screen option,on your dashboard,and un check it from quere,also go to your comment, quicj edit and uncheck it

  4. timfreed2, i found the way to disable the function.

    Go to the edit page of the page you want to disable the function. Click screen option on the right top screen. Check the box of discussion. Then the option of Allow comments will appear at the bottom of the edit page. Then uncheck the box. The comment box will disappear on that page.

  5. Thank you catezapp.

  6. my pleasure

  7. So, I am having the same issue/want the same thing (to entirely disable comments across this whole blog/site), but when I go to "Screen Options" and click to show discussion/comments boxes...

    i don't get a box that says "allow comments" - only "add comment", so that i can comment on a post or page.

    any other suggestions? css? anything?

    thanks in advance!

  8. This page > Settings > Discussion
    Discussion settings is where you set up defaults for comments.
    http://en.support.wordpress.com/settings/discussion-settings/

    We can also override the default settings and enable or disable future comments on any individual post or page.
    http://en.support.wordpress.com/enable-disable-comments/

    Note 1: By default, new blogs on WordPress.com will have the Discussion hidden. You can reveal it by clicking on Screen Options http://en.support.wordpress.com/screen-options/ on the top right corner of your Admin page, and checking the box that says Discussion so the module is included. http://en.support.wordpress.com/modules/#list-of-modules

  9. @hpmsnews:
    a) To disable commenting for future posts or pages, you go to Settings > Discussion, uncheck the options "Allow link notifications" and "Allow people to post comments", scroll down and click Save Changes.
    b) To disable commenting for your already published posts, you go to Posts > All Posts, tick the little square to select all the posts, select "Edit" from the Bulk Actions pulldown, click Apply, select "Do not allow" from the Comments and Pings pulldowns, click Update.
    c) To disable commenting for your already published pages, you go to Pages > All Pages, tick the little square to select all the pages, select "Edit" from the Bulk Actions pulldown, click Apply, select "Do not allow" from the Comments pulldown, click Update. If the pages aren't all listed on the same screen, click the top right arrow to repeat for the next screen.

  10. YAY! justpi, that resolved it. thank you!! - ms

Topic Closed

This topic has been closed to new replies.

About this Topic