Need help? Check out our Support site, then


How do I enable XML-RPC API in WordPress?

  1. WordPress remote API not enabled!

    It looks like you don't have the XML-RPC API enabled in WordPress, or perhaps the website located at http://golfwisdomlife.wordpress.com/wp-admin isn't powered by WordPress. Please log into your WordPress admin panel, then go to Settings > Writing > Remote Publishing and check the box next to 'Enable the WordPress, Movable Type, MetaWeblog and Blogger XML-RPC publishing protocols.'

    I can get to Settings>Writing> ??? Where do I find "Remote Publishing"
    Blog url: http://golfwisdomlife.wordpress.com/

  2. WordPress.com sites have XML-RPC activated by default, but the "endpoint" for your blog is http://golfwisdomlife.wordpress.com/xmlrpc.php, not /wp-admin.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags