Need help? Check out our Support site, then


How do I fix a home page with a messed up format?

  1. Formatting on my home page has lately gone haywire. The right hand column where the archive list, etc. was is now replaced with an older article. The archive list, etc. is at the bottom of the page. Fonts on older articles have become very small and go wide beyond the edges/margins of the page, right and left. Pictures are not affected. Oddly only postings from last September and before seem to be affected. Those since September display correctly.

    One day I turned on the site and that's the way it was: formatting freak out.

    Is there an update or setting that needs to be done?

    The blog I need help with is nightwatch1.wordpress.com.

  2. Yes, HTML errors. Try this:

    Go to Settings->Writing and select "Wordpress should correct invalidly nested XHTML" and save.

    Then go to the Posts page of your dashboard, set the last 20 posts to Private, update, then set them public and update. This causes the setting above to take effect.

    If that doesn't fix it, you need to do the previous 20 posts, and so on. You may need to check the code in your text widgets as well to make sure it's perfect.

  3. @Raincoaster. Thanks. I'm trying what you've suggested, but it doesn't appear to be helping (though I'm not sure I'm doing it right). You're working with an old old guy here. (I didn't even know those settings existed and I'm not sure what they do.)

    I've always run with the defaults, then one day the page is all messed up and I don't have a clue why. Oddly enough if I click on a single article it comes up clean. It's just the main page that is screwed up.

    I did the Settings > writing and I tried the Post page, Private, update, Public, update. It didn't seem to work. I couldn't really figure out the widgets or what code I need to check. I can try again later, but I don't really know what I'm doing.

  4. The problem is in this post:
    http://nightwatch1.wordpress.com/2012/10/23/obama-gets-away-with-incredible-fraud/
    Edit the post, switch the editor to "Text"; you'll see this before the second paragraph:
    </div>
    Delete it, click Update.

  5. @justpi -- Thanks! Absolutely fantastic. That little edit did it. Everything went back to normal, instantly. You really know your stuff. Thank you so very much. I really appreciate it. Happy Thanksgiving.

  6. You're welcome!
    For more on this see this post of mine:
    http://wpbtips.wordpress.com/2012/05/19/sidebar-at-the-bottom-and-related-issues/

  7. @ justpi -- Very interesting posting. I'm not sure I followed all of it (you're talking to an old old guy), but I thank you again for helping me out.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.