Need help? Check out our Support site, then


How do I get images to show on my page?

  1. I am using the theme SIGHT.
    On the demo it shows images on the homepage next to the text.
    When I create a webpage, however, it only shows the text and you have to click on "continue reading" to see the image. How can I get the image on the home page???

    The blog I need help with is thebigexcellent.wordpress.com.

  2. Suffice to say that on any theme with an active excerpt box below the editor box you can use this workaround to have full posts on the front page.

    You compose your whole post first and before you publish it you switch to the HTML (Text) editor, copy all the code, paste it into the Excerpt box below the posts editor, and publish the post. http://en.support.wordpress.com/splitting-content/excerpts/#creating-excerpts

    If you do not see an excerpt box then go to screen options on the top right hand corner of your Admin page and include:
    Post – Likes and Shares, Format*, Categories, Tags, Excerpt, Send Trackbacks, Discussion, Comments**, Slug, Author, Revisions, Writing Helper

    P.S. On themes that do have an active excerpt function, the workaround works very well but you have to do it on every post you create.

  3. Thank you for your response. I have tried both methods and neither works. The theme doesn't have an excerpt box. Withint the post, I clicked on all the categories and (1) they don't remain checked (2) I repeatedly re-check them and the image still doesn't appear on the blog.

    The demo for the theme HAS images. I'm finding it odd that only a short excerpt with no image appears...

  4. For most themes that have a slider, header, or some other fancy way of displaying your featured content, you can't see it "work" until you've added at least 5 or so posts and put them into a certain format. There are two things that are needed on these posts:

    1. Each post's visibility setting needs to be set to "sticky".
    http://en.support.wordpress.com/posts/post-visibility/

    2. The post needs to have a featured image that meets the dimensions required for that theme.
    http://en.support.wordpress.com/featured-images/

    For the Sight theme, the dimensions are shown at the bottom of this page:
    http://theme.wordpress.com/themes/sight/

    You may want to also add the following CSS to your site, by visiting the CSS tab of your Appearance -> Custom Design page:

    h1.site-title, h1.site-title a {
    font-size: 72px!important;
    line-height: 72px!important;
    }

    This will reduce the size of your site title text so it's more proportionate to the surrounding content.

  5. The theme doesn't have an excerpt box.

    Hello,
    You are speaking to someone who has used this theme and who has done what I stated above. I never give instructions like this for anything I do not know for a fact that do work. I have Sight up on my test blog and it worked fine for me.

    Please try again. There is an excerpt box below the editor box http://en.support.wordpress.com/splitting-content/excerpts/
    I copied and pasted the image code from the Text (HTML) editor into it and published the post. i have an image displaying.

  6. Holy guamcamole! This is a CSS forum question. Who knew?

  7. I don't think it needs to be moved to the CSS forum. The initial question related to how to set up the Sight theme, which doesn't depend on CSS.

    Having checked out the site though, I think thebigexcellent may prefer to reduce the size of the site title for use with the Sight theme. The way a longer title wraps onto additional lines is a bit disproportionate compared to how the demo looks.

  8. First of all, thank you for your help and patience. Secondly, I have now added or re-edited 9 blogs adding "sticky" and adjusting image size.

    I feel as if I must be getting closer to success, but it is still not posting images on main page.

    Will change the title font size as soon as I get through this image craziness - thanks for suggestion and solution on that.

  9. You're getting closer ;-)

    On your most recent post, I see that you've added an image, but it wasn't set as your featured image:
    http://thebigexcellent.wordpress.com/2013/01/12/pagels-dioramas-are-excellent/

    This is a module that appears below the Categories and Tags area of the right side of the screen, when you're editing a post. See this screenshot:

    http://en.support.files.wordpress.com/2013/01/featured-img.jpg

    This page explains more about featured images:
    http://en.support.wordpress.com/featured-images/#setting-a-featured-image

    You'll get the best result if you upload an image with the same dimensions suggested in the theme spec: 290 pixels in height by 640 pixels in width.

    There are tips for optimizing images, along with links to free image editors, here:
    http://en.support.wordpress.com/media/image-optimization/

  10. Happiness Engineer, indeed! Kindness of strangers, as well.

    So I set a few images as featured image and now I have three images "rotating" as featured. Not exactly like SIGHT looks on the preview page, but another 1/2-step closer.

    Images are going to be an integral part of my site concept... starting to wonder if I'm pushing too hard against the template.

  11. You're not pushing at all!
    For posts/images in the slider, you set a featured image to each post and you mark each post as a sticky (as debeckett explained).
    For images in the post excerpts below the slider, again you set a featured image to each post, without marking the post as a sticky.

  12. That's right, you can see images on the posts running down the homepage by setting featured images on those posts as well (but *not* making them sticky).

    Again here it's best to refer to the dimensions recommended on the theme details page:
    http://theme.wordpress.com/themes/sight/

    The recommended dimensions for featured images for the non-sticky posts is 290px by 290px.

  13. Wow! It's working! I feel like a programmer.
    A few (final?) questions:

    What is this sort of banner image/post and how can I get rid of it? On the current page it is the "Welcoming in the new..." image with the ruin. I didn't try to make this featured and can't get it to scroll through images nor can I seem to change it or remove it.

    Any way to have more than one image per post showing on home page or am I pushing my luck?

    Thank you again!!

  14. 1) What do you mean "What is this sort of banner image/post" and "I didn't try to make this featured"? Posts don't show up in the slider automatically: as we explained, to make a post show up in the slider you make it a sticky post. If you don't want that post in the slider, go to Posts > All Posts and edit the post to unsticky it.

    2) "can't get it to scroll through images". The slider doesn't showcase images from a post, it showcases posts.

    3) "Any way to have more than one image per post showing on home page"? To do that you need to create custom excerpts. You need to copypaste the image codes from the Text editor into the Excerpt module, as timethief suggested. You replied that "the theme doesn't have an excerpt box", but that's not right - you just didn't pay attention to her whole reply: if you're not seeing the Excerpt module while on the post editor screen, you click Screen Options (top right) to activate it.

  15. @thebigexcellent

    Any way to have more than one image per post showing on home page or am I pushing my luck?

    Good morning. You have come full circle back to what I posted above in my first response. http://en.forums.wordpress.com/topic/how-do-i-get-images-to-show-on-my-page?replies=14#post-1121872

  16. Thanks for this - and good morning!

    On the slider, Justpi wrote:
    "Posts don't show up in the slider automatically: as we explained, to make a post show up in the slider you make it a sticky post. If you don't want that post in the slider, go to Posts > All Posts and edit the post to unsticky it."

    I did "unsticky" it as I unsticky-ed all the posts. I have added a "featured" image for each and removed sticky. On all the posts. But this one is still at the top of the blog with a yellow-highlighted box next to it. I can't seem to get it off or change it.

  17. You must have somehow missed that one. Go to Posts > All Posts: it should say "Sticky" next to the post title. If so, hover over the title, click Quick Edit, uncheck the option "Make this post sticky", click Update.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags