Need help? Check out our Support site, then


How do I get my photo posts to display on the homepage?

  1. I'm using the Hatch theme, I cannot see photos I uploaded from my computer on my homepage- I can only view them after I click on the post link. I'm using Google Chrome.

    The blog I need help with is mirandadoesphotos.wordpress.com.

  2. Everything you need to know about using your theme can be found on the Theme's Showcase page. http://theme.wordpress.com/themes/hatch/

    But I think the problem you are encountering has to do with how you inserted the image in your post. Did you upload the photo via the "Add Media" button in the post or was it uploaded via the Media Library and then inserted into the post using the "Add Media" button?

  3. To upload the photos I went to 'New Post' "photos' 'upload photos' and 'choose file' from My Documents on my computer.

  4. And you uploaded each file individually to each separate post and then inserted it in the post or also marked it as a Featured Image?

    Here's what it says in Hatch's Theme Showcase page

    If no featured image is assigned, Hatch will attempt to pull the first attached image in your post. If no image is attached, the theme displays a light gray placeholder.

    So from my understanding the photo you inserted in your post should also appear on the front page of your site if it is at least 640 pixels wide, which your images are.

    Perhaps the Theme Team can shed some light on this and I've tagged this for their assistance.

  5. Thank you for helping me. I did not tag anything as a featured image and did not use the media library I simply chose the photo file from my documents, each photo is uploaded separately to its own post.

  6. I went to my dashboard >media > and in the media library i could see the photos I uploaded but in the "Uploaded to" column they weren't attached to anything. I selected 'Attach' and chose the corresponding blog post and I can now see the images on my homepage. Does this theme/wordpress not automatically attach the photos to the posts when you initially make a photo post?

  7. Does this theme/wordpress not automatically attach the photos to the posts when you initially make a photo post?

    No. That's not default behavior of WordPress. "Uploading" and "Attaching/Inserting" are two different actions. You need to click the blue button "Insert Into Post" or "Set featured image" (If you are setting a featured image).

    Hope it helps.

Topic Closed

This topic has been closed to new replies.

About this Topic