Need help? Check out our Support site, then


How do I get site stats to work on iPhone / iPad apps?

  1. None of my site apps work on my iPad or iPhone apps. I have tried removing sites, deleting app, reinstalling and re-adding sites but they still don't work.

    It affects all my WP.com sites but these are the ones tha matter the most:

    allfivehorizons.wordpress com
    becomingmiss.wordpress.com
    Blog url: http://allfivehorizons.wordpress.com/

  2. Would you please tell us which version of the app you are running, and which iOS version?

  3. Sorry, i should have said: On both devices I'm running iOS 5.1.1 and WP app version 3.0.

  4. That is definitely the latest.

    Do you have any luck if you completely delete the app and then reinstall it?

  5. No tried this a couple of times - the stats have never worked and I finally decided to find out why (maybe they are so inadequate, the app is trying to save me from the truth!).

    The pages didn't work for ages either but the second to last delete/reinstall did add them correctly but still no stats.

  6. This is rather odd. Have you tried over both cell network and wi-fi?

  7. Yes, my iPad is wifi only and I've tried both for my iPhone.

  8. Hm, and it affects every WordPress.com blog on this profile?

  9. Yes I haven't got it working on any blogs. The becomingmiss.wordpress.com is relatively new and this doesn't work either.

    My stats on the dashboard appear to work fine, by the way. It's only through the app. I get the message saying 'never updated' and the round cursor appears like its updating but nothing happens even if left for long periods.

    If its just one of those thing, don't worry. It's not the end of the world! Thanks for your efforts.

  10. Version 3.0.1 was just released and has better error reporting.

    Please try that, and if you still have trouble, please quote the error you receive.

  11. Hi

    Have upgraded both devices (actually deleted app, reinstalled and updated then re-added blogs) - still no stats and no error. It just hangs here:

    Screengrab

  12. Hi there,

    I'm sorry to hear that you are still having issues with this. Unfortunately to be able to help you out, we'll need some extra information that you will need to obtain from your app. The steps are outlined here:

    http://dev.ios.wordpress.org/extra-debug/

    Would you mind following these and either reply back with the details or email us privately at support@wordpress.com and refer back to this thread.

    Thanks and sorry about the trouble! :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.