Need help? Check out our Support site, then


how do I remove the 'comments' link on the first page in my blog?

  1. susanlambertdesigns
    Member

    I've tried everything! How can I remove 'comments' and 'leave a comment'??? thank you!

    The blog I need help with is susanlambertdesigns.com.

  2. This page > Settings > Discussion
    Discussion settings is where you set up defaults for comments.
    http://en.support.wordpress.com/settings/discussion-settings/

    We can also override the default settings and enable or disable future comments on any individual post or page.
    http://en.support.wordpress.com/enable-disable-comments/

    Note: By default, new blogs on WordPress.com will have the Discussion hidden. You can reveal it by clicking on Screen Options http://en.support.wordpress.com/screen-options/ on the top right corner of your Admin page, and checking the box that says Discussion so the module is included. http://en.support.wordpress.com/modules/#list-of-modules

  3. susanlambertdesigns
    Member

    I did that... the enable/disable comments and it's still there. Is it because I am using a template?

  4. susanlambertdesigns
    Member

    anyone? Can you take 'comment' off a page????

  5. Yes, we can also override the default settings and enable or disable future comments on any individual post or page.
    http://en.support.wordpress.com/enable-disable-comments/

  6. susanlambertdesigns
    Member

    I did just what it says and it's still there. I don't want it to be on the page at all. If you look at my page
    http://www.susanlambertdesigns you can see 'comments' and 'leave a comment' it won't go away ............

  7. No, you didn't do what it says, because you didn't read the doc carefully enough. Disabling comments in Settings > Discussion has no effect on already published pages. You need to edit the pages and disable comments in the Discussion module of the page editor. Faster way: go to Pages > All Pages, tick the little squares to select the pages, then follow steps 3-6:
    http://en.support.wordpress.com/enable-disable-comments/#bulk-editing-comments

  8. susanlambertdesigns
    Member

    I have done both justpi and the 'comments' display is still showing. Possibly you don't understand what I am trying to do. I edit the page, I disable comments, I save, I preview, and 'comments' (the word in green) is still there. I also did the 'all pages' thing.

  9. If you had done either successfully, there would be no green tab, no grey tab, no "Leave a Reply" heading and no reply field.

    Repeating the exact steps, just in case you've missed some step:
    Fast method: Pages > All Pages; check the little squares to select all the pages, select Edit from the Bulk Actions pulldown, click Apply, select "Do not allow" from the Comments pulldown, click Update.
    Slow method: Pages > All Pages; hover over page title, click Edit, uncheck "Allow comments" and "Allow trackbacks and pingbacks on this page", click Update; repeat for rest of pages.

    If you tried all that and it won't work, then maybe you're having a browser issue. Try clearing your browser's cache and cookies. What browser and version are you using?

  10. susanlambertdesigns
    Member

    well it's obviously possible. I have gone to 'screen options' and made sure the comments box is unchecked. I went to 'all pages' hovered over the page title clicked edit and see no 'allow comments' but there is 'screen options' and comments is not clicked.
    Then I did 'all pages' same thing I see no 'allow comments'
    so somewhere I'm missing something.
    I am in another place on another computer right now so it isn't the browser cache or cookies. it's the person behind the keyboard.... me.... ready to give up.

  11. Don't give up - we'll sort this out!

    I have gone to 'screen options' and made sure the comments box is unchecked.

    That's a mistake: screen options determine what is visible on the particular dashboard screen, not on your actual blog pages. You need to edit each page, check Discussion in Screen Options so that the Discussion module will show up, then uncheck comments and pings in the Discussion module, then click Update.

  12. susanlambertdesigns
    Member

    When I edit the first page, and click discussion in screen options no module shows up. nothing changes.
    you are very nice to help thank you

  13. It's not a popup window (in case that's what you were expecting), it's a box that should show up somewhere below the main edit box.

  14. susanlambertdesigns
    Member

    thank you! it was wayyyyyy down under everything at the bottom of the page.
    I knew it had to be simple because you kept telling me where to find it.
    geesh..........
    Much much much appreciated!
    thanks!

  15. You're welcome!

Topic Closed

This topic has been closed to new replies.

About this Topic