Need help? Check out our Support site, then


How do I remove the "Leave a Reply" from pages I already created?

  1. I want to remove the "Leave a Reply" box from all my pages except for my blog page. I've read the instructions, but when I try to click the title of the page I want to change, nothing happens. If I click "edit" and go into the dashboard and look under settings and discussions, a long list of options comes up, not the one shown in the tutorial. I don't want comments on my pages, only on my blog posts.
    Blog url: http://stageitrightwithstageright.wordpress.com/

  2. This page > Settings > Discussion
    Discussion settings is where you set up defaults for comments.
    http://en.support.wordpress.com/settings/discussion-settings/
    We can also override the default settings and enable or disable future comments on any post or page.
    http://en.support.wordpress.com/enable-disable-comments/

    Note: By default, new blogs on WordPress.com will have the Discussion hidden. You can reveal it by clicking on Screen Options http://en.support.wordpress.com/screen-options/ on the top right corner of your Admin page, and checking the box that says Discussion so the module is included. http://en.support.wordpress.com/modules/#list-of-modules

    I want to remove the "Leave a Reply" box from all my pages except for my blog page.

    Depending on the theme we use when we close comments a phrase like “comments closed” or "leave a reply" or a similar phrase may appear and if so, it can only be removed by CSS editing after purchasing a custom design upgrade.
    http://en.support.wordpress.com/custom-design/
    http://en.support.wordpress.com/editing-css/

  3. Fast way to do it: go to Pages > All Pages, tick the little square to select all the pages, select Edit from the Bulk Actions pulldown, click Apply, select Do Not Allow from the Comments pulldown, click Update.

Topic Closed

This topic has been closed to new replies.

About this Topic