Need help? Check out our Support site, then


How do I stop hyphenation in the sidebar?

  1. strosemetropolis
    Member

    I recently created a new web site and blog for my church using the WordPress.com "Twenty Ten" theme, at http://strosemetropolis.com/. Recently, I have noticed that several words in the sidebar widgets are getting hyphenated automatically, rather than just having the entire word move to the next line. For example, previously I had a link which displayed as:

    Today on the Liturgical
    Calendar

    Now it displays as:

    Today on the Liturgical Calen-
    dar

    How do I stop it from hyphenating words like that? In my opinion, it looks bad. And at least in this particular case, it doesn't actually save any vertical space. (It's also not clear to me why words that weren't hyphenated a few days ago suddenly are hyphenated now.)

    The blog I need help with is strosemetropolis.com.

  2. strosemetropolis
    Member

    One thing that occurs to me: I have recently added at least two new widgets to the sidebar. Could it be that increasing the number of widgets is what caused the hyphenation to kick in, perhaps as an attempt to save vertical space? And would that mean that I could stop the hyphenation by removing some widgets?

  3. I do not see any hyphenation using FF16.0.1, Chrome 22 or IE8.

    How are you connecting to the blog and viewing it? The main dashboard isn’t designed to work with touch devices through the tablet and smartphone browsers.

    Exactly which browser and version of it are you using. If you aren’t sure click here to find out > http://whatsmyuseragent.com/

    Note: If you are using an IE9 browser in compatibility mode that makes it render as IE7 and IE7 is not supported. To disable see > http://www.sevenforums.com/tutorials/1196-internet-explorer-compatibility-view-turn-off.html

  4. strosemetropolis
    Member

    Thanks much for the reply, and for checking in all three of those browsers.

    This is strange: I checked my site again on a different computer, and now I do NOT see the hyphenation. On both computers, I am using the latest version of Firefox (16.0.1). One computer has Windows Vista; the other has Windows 7.

    Maybe it is my web browser that is doing the hyphenation? I need to check my Firefox settings and see if Firefox has some automatic hyphenation setting that I'm not aware of.

  5. strosemetropolis
    Member

    I checked in the Firefox options, as well as Firefox online help, and I couldn't find anything about automatic hyphenation. So I'm not sure whether to blame my browser settings on that particular computer or not.

    I will try viewing my site on several different browser versions, and hopefully on one additional computer as well. I will post back here with what I find. In the meantime, if anyone knows the solution to this mystery, please let me know. Otherwise, if I find that it only happens on that one computer with that one browser, then I guess it's not worth worrying about.

  6. Is it on the windows Vista using FF 16.0.1 that you see hyphenation? I don't see it on windows XP or on windows 7 using FF 16.0.1.

  7. strosemetropolis
    Member

    Is it on the windows Vista using FF 16.0.1 that you see hyphenation?

    Yes, it is the Windows Vista system where I see the hyphenation in Firefox. When I have time later, I will try other browsers on that same computer, and on a third computer, and I will update here.

  8. strosemetropolis
    Member

    This morning, I viewed my site using three browsers (IE 9.0, Chrome 22, and Firefox 16.01) on each of three different machines (a Windows Vista desktop, a Windows 7 desktop, and a Windows 7 laptop). Here is what I found:

    • I do not see any hyphenated words in my sidebar in Chrome or Internet Explorer, on any of the three machines.
    • With Firefox 16.0.1, I do see hyphenated words in the sidebar on two of the three machines (the Windows Vista desktop and the Windows 7 laptop). Specifically, four words in my sidebar are hyphenated, and the words are not all in the same widget. (The words are "Fridays," "Calendar," "toilet," and "cleaning.")

    I suspected that perhaps I had "zoomed in" with Firefox on my site, causing the text size to increase, and that maybe that had somehow triggered the hyphenation. But on both systems where I saw the hyphenation, I verified that I was at the default zoom level in Firefox (by clicking View > Zoom > Reset, from the menu bar). So that is not the explanation.

    It seems to me that the Twenty Ten theme must have some setting that causes automatic hyphenation of words in certain circumstances. If that is the case, I would like to know if there is a way to turn off that setting, or a way to design the sidebar so that hyphenation doesn't kick in.

    I really don't think that my browser is doing the hyphenation, because don't recall seeing hyphenated words on any non-Wordpress sites with Firefox. (However, I did check another WordPress blog that uses the Twenty Ten theme, with one of the browsers where I see the hyphenated words, and sure enough, several words in the sidebar of that blog are hyphenated too.)

    I guess that this issue is not a very big deal, especially since it doesn't happen in all browsers. Nevertheless, if anyone can tell me a way to stop this automatic hyphenation from happening, I would certainly appreciate it. :-)

Topic Closed

This topic has been closed to new replies.

About this Topic