Need help? Check out our Support site, then


How do you set the maximum image size?

  1. I go to the "Settings" page and click on the "Media" tab.

    The default setting for the "Medium" width/height is 300 x 300, and the default setting for the "Maximum" is 500 x 500.

    I changed the "Maximum" values to 450 x 450.

    Then I went to my blog and clicked on the "Add an Image" icon.

    I select an image that is 722 x 410 in size to upload.

    After the upload the following sizes are displayed by the upload manager:

    Medium: 300 x 170 - this makes sense

    Large: 500 x 283 - Why is this not 450 x 256, since I specified the maximum width to be 450 above?

    Full Size: 500 x 283 - Why is this not 722 x 410?

    When the image is used in the blog I looked at the height/weight parameters in the HTML and they also use 500 x 283 so it appears I don't understand the concept of using the "Settings / Media" page to control image size. What am I missing?

  2. did you try the design tab, and the edit css page? at the bottom there's limit content width option

  3. You can change the max width I height by going to Dashboard->Settings->Media

  4. "did you try the design tab, and the edit css page? at the bottom there's limit content width option
    "

    I don't have the CSS upgrade. I noticed no difference when I clicked on the "Preview" button after updating width value.

    "You can change the max width I height by going to Dashboard->Settings->Media"

    That was the first thing I tried as I stated on the first line of the posting. Have you tried this? Did you have the problems I described?

    My question is about trying to understand the settings. How do they work? Do I have unrealistic expectations about what those values mean?

    Any clarity would be helpfull.

  5. Have you tried searching the FAQ or the forum ?

    Search for “image up loader & media settings « OneCoolSite”

  6. I've tried searching all over the place but have found nothing. Thanks for the link but that new link does not address my question (at least from all the entries I read I couldn't find an answer).

    The image is uploaded correctly and displays correctly, it is just displayed at the wrong size.

    I know how to manually solve the problem. Once the image is added to a blog you:

    a) click on the image
    b) click on the "edit" button on the top left of the image
    d) click on the "Advanced Settings"
    e) enter the width(450), height(256)

    The question is why do I have to do this?

    As you suggested earlier I should be able to use Dashboard / Settings / Media to control the maximum width for the large sized image. That way the 700 image pixel should be scaled to 450, instead of the default 500.

    It seems to me like the uploader is using the default value and not the value from the settings page.

    Can anybody confirm if this is the case or not?

  7. But have checked marked full size in those settings,
    this is ask for reference reasons because sometimes
    I accidentally uncheck mark settings with out realizing it.

  8. But what happens if you do change the "Large Size" to be 450 x 450 and then check the "Default Image Size" to be "large" (instead of full size).

    Is your image automatically scaled to 500 (the default), or does it work correctly for you and get scaled to 450?

    Is this a bug? Should I be posting the the support forum instead?

  9. camickr - you might want to contact support on this. I'll be honest - I never upload images that are larger than those allowed by my theme.

  10. Here is the link for Support

  11. No Support please!

    camickr, you have confused some things: First, large, maximum and full size are not the same thing, and second, there's no option for "maximum" in the Media Settings or the uploader.

    Large normally means a particular size you specify. Full size means the actual size of the image, PROVIDED it doesn't exceed the maximum width allowed by the theme (500px in your case).

    You must keep in mind that the post editor and the image uploader is a general tool, but the behavior varies depending on the theme. Some themes have flexible width, so they can accept very large images. Fixed width themes may show part of the image, if it's wider than the main blog column, or may scale it down to fit. That's why you got 500 for "Full size". The only detail I don't understand at the moment is why you also got 500 for "Large" despite your 450 setting.

  12. > I never upload images that are larger than those allowed by my theme. <

    That is why I'm trying to do this. I found this great link that shows the maximum sizes of an image for each theme

    http://faq.wordpress.com/2006/09/25/how-big-can-my-images-be/

    So I choose the smallest image size of the themes I'm interested in using so I an swap back and forth if I wish.

    > The only detail I don't understand at the moment is why you also got 500 for "Large" despite your 450 setting. <

    And that is the whole point of my question. I don't understand it either.

    Being new to the world of blogging in general and WordPress specifically, I was just wondering if I was missing something obvious. It appears not.

    I will contact support. Thanks for your time.

    , which is why I think it is a bug.

  13. @camickr: To be precice, that may have been the whole point of your question, but it wasn't your only question.

    Anyway, till we clear this up, let me note (re your Oct 8, 2008, 11:48 PM remark) that there's a faster way of changing the size of an image after you've uploaded it: you go to the HTML post editor, remove the height command from the code so you don't have to calculate that dimension, and change the two occurrences of the width number to any number you wish.

    (Generally, it's not good to exceed the width of the theme, because this may mess up your blog, sending your sidebar to the bottom.)

  14. I submitted this to support and received the following reply:

    You have found a bug. We have reported it to the developers and they are working on it. Thank you very much for your detailed explanation of the problem as well as your participation in the forums. It is appreciated!

    How do I close this to future postings? I changed the topic status to "resolved" but it doesn't seem to do anything.

  15. As the Original Poster (OP), you can mark it as "resolved", but only Staff can mark it "closed". There may be other people interested in adding to the discussion. If after about a month there's been no new replies, the thread will automatically close itself to new replies.

  16. Thanks.

  17. I must have missed the announcement on the automatically close thing. (And if they can do it in the forums, by golly, they should give us that option on our blogs!)

  18. Don't actually know if there was an announcement, Vivian, but that's about how far back they seem to run. In the "Questions" forum, the closed topics start around page 27. I haven't checked all the forums.

    Options are always good. Don't think I'd use it on my blogs, but that's just me.

  19. Follow up. I just noticed today that this problem has been fixed.

    Thanks for the quick support.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags