Need help? Check out our Support site, then


How the heck can I download a picture?!?

  1. The site is simply not alowing me to download pictures! That little circle that means "downloading" goes on and on and ON, but nothing happens, it doesn't download! I'm wondering if this happens because the post site that comes up has changed from the one I always used to use, which was much easier. That one used to have an icon for downloading an image, and you could pick the size of the image and where it went. The post site I get now just has something that says "download photo," and maybe that's the wrong thing and that's why it isn't working.
    Blog url: http://trinarobbins.wordpress.com/

  2. We are here for support of blogging on WordPress.com. Downloading from the internet to your computer isn't really a part of that. Perhaps Google has some solutions for you?

  3. I'm not trying to download from the internet! I'm just trying to download images from my own folders into my blog post, which I have done successfully in the past when the site had a different design and was easierfor me to use!

  4. Ah, that's not downloading: that's inserting. What browser and version are you using?

  5. There must be an issue with wordpress right now.

    I can use the media uploader, I can't access tags, etc. Have restarted my computer to no avail. I see several posts with the same issues - so WordPress must be having issues.

  6. Right, inserting a picture is what I want to do! Please excuse the fact that I am technologically challenged. My browser is Internet Explorer, version 7 I think, or whatever's current.

  7. Timethief, that site doesn't help. My images are low rez, and I used to be able to insert them, now suddely I can't anymore. mtoddsmedley, how long have you been having similar problems? Around the 2nd week of July, I had to put up my last blog without images, because I couldn't insert them.

  8. The most recent version of IE is IE 9. Try using a different browser, such as Firefox and see if that works.

  9. I have the same problem. When I try to upload a picture into a new post it never actually uploads. I have to go through my dashboard to do a new post and insert media. I think the insert media issue is a problem with the site right now because a lot of people cannot insert media.

Topic Closed

This topic has been closed to new replies.

About this Topic