Need help? Check out our Support site, then


How to add another administrator?

  1. I'm trying to add another admin to my blog, and everything seems just fine, he accepts the mail he gets, and follows the activation link. It even says that he's in - but he isn't. Can't find him anywhere, not in his or my profile. What to do?

  2. You did not specify a blog address or reason for posting when you created this topic.

    This support forum is for blogs hosted at WordPress.com. If your question is about a self-hosted WordPress blog then you'll find help at the WordPress.org forums.

    If you don't understand the difference between WordPress.com and WordPress.org, you may find this information helpful.

    If you forgot to include a link to your blog, you can reply and include it below. It'll help people to answer your question.

    This is an automated message.

  3. @vegardmoberg
    If you are referring to the blog linked to your username then these two support entries are the ones you need to consult.
    http://en.support.wordpress.com/user-roles/
    http://en.support.wordpress.com/adding-users/

  4. Both of you, should log out of wordpress, clear your browser cache and cookies, restart your browser and then take another look. It could be a cookie or browser cache issue.

  5. The other thing I always suggest is to not make anyone an administrator on your blog, because that gives them the ability to completely wipe out your blog, post, pages, etc., and there have been far more than a few show up here in the forums with just that problem. There is a disagreement or falling out and poof, the blog is gone.

    Just something to keep in mind.

Topic Closed

This topic has been closed to new replies.

About this Topic