Need help? Check out our Support site, then


How to adjust the number of blog posts on homepage?

  1. My blog posts appear on my "homepage" and I want to only show the most recent 5 posts. I have updated the settings, but every single post still appears. I have checked the support forums and can't find out how to adjust this...please help! Thanks!

    The blog I need help with is brandiebee.wordpress.com.

  2. Have you set that here?
    Settings > Reading
    Blog pages show at most __ posts
    Have you also disabled infinite scroll on that same page?
    To infinity and beyond __ Scroll Infinitely
    (Shows 7 posts on each load)
    "save changes"

  3. infinite scroll! that was it. thanks!

  4. I thought so. You're welcome and best wishes with your blog.

Topic Closed

This topic has been closed to new replies.

About this Topic