Need help? Check out our Support site, then


How To Disable Comment Function

  1. I want to disable the comment function on some of my pages, and I was told to go to "Screen Options" and then to the box "Discussion". This box, however, doesn't exist.

    The blog I need help with is messianic613.wordpress.com.

  2. You'll only see the selection in the Screen Options tab when editing the post or page in question.

  3. Even when actually editing the page there appears no box "Discussion" as displayed on the the Support Screen. There appears an item "Discussion" but one can not do anything with it. It has no effect when one touches it. It shows no disabling function. Its appearance is not like the one on the Support Screen at all.

  4. Maybe this will do it? This will set comment moderation settings on posts. I'm only guessing that the same settings will apply to pages, but an experiment that I just tried suggests that they do. I visited one of my own pages using a different wordpress.com membership, tried leaving a message, and sure enough, it landed in the queue, waiting for the moderator to approve it.

    Start on the dashboard for your blog. Go to the bottom of the left hand side of the screen, where you'll find "settings". Click on the arrow to the right of that word, and you'll get a drop down menu. Choose "discussion" out of that menu (4th item down). The 4th block of choices down on the page you come to will read "Before a comment appears". One of your choices is "an administrator must always approve the comment", which won't turn off commenting, but at least it will allow you to screen comments and refuse any or all of them, without the need for you to do anything.

    The top block reads "default article settings", and includes the option "allow people to post comments on new articles", which can be unchecked. This won't help you with old material, but it should allow you to disable commenting altogether on new material. I think.

  5. Messianic - I think you might find your Discussion option is not ticked in the Screen Options.

    Click on Screen Options on the upper right hand side of your edit screen - beside the Help tab, and check if Discussion is checked/ticked.

    I had the same problem myself!

  6. Thank you all for your help. I have found it.

Topic Closed

This topic has been closed to new replies.

About this Topic