Need help? Check out our Support site, then


How to enable/disable comments for individual posts?

  1. Hi,

    By default, comments are allowed on my blog. However, having read the Support page entitled 'Enable and Disable Comments' a couple of days ago, I attempted to disable them for just one post. The support page, and also the Settings>Discussion>Default Article Settings page in the blog itself (accessed via the Dashboard), suggest that this is possible (i.e. on the Discussion Settings page, under 'Allow People To Post Comments on New Articles' it says "These settings may be overridden for individual articles").

    I tried a few test posts but I couldn't make it work, and therefore I abandoned the idea.

    The following day I posted a new article, and rather to my surprise received no comments. I've had an email this morning, though, from a regular poster who said that he was sending some feedback in email because he isn't able to post on my blog. I logged out and went over, and sure enough the most recent post doesn't allow people to post comments. There's a 'Leave a Comment' link, but clicking on it doesn't bring up a comment box.

    I've tried really hard to work out why that has happened, but I'm completely confused by it. When I Edit the most recent post and then go to Settings>Discussion>Default Article Settings there is a tick in the 'Allow People to Post Comments on New Articles' box. There's still no way to comment, though, and 'Default Article Settings' suggests that any changes made there will apply generally, rather than to the individual post. Try as I might, I've been unable to find any way to alter the setting that seems to apply to an individual post rather than posts generally.

    Despite all that, it does seem to be possible still to comment on the other posts on my blog. Just the most recent one seems to have been affected.

    Can anybody please help? Maybe I'm overlooking something really obvious (wouldn't be the first time), or possibly I have an old version of the software, or something. I've searched in here but haven't been able to find an answer. Many thanks for any help.

    The blog I need help with is peewiglet.wordpress.com.

  2. When you said you tried it and it 'didn't work" can you confirm that the comment box was visible on the posts? Because you can't get rid of that "Leave a Comment" link, even if you've disabled comments. Did you maybe just look at the front page and conclude nothing had changed?

  3. Hi Raincoaster,

    Thanks for helping.

    In fact, sometimes it did work and other times it didn't. What I did was make a few test posts and then log out, go over as though I was a guest and try to comment.

    I did actually go into the posts each time, rather than just looking at the front page. On each occasion a comment box was visible, and I was able to write in it and press 'Submit', but sometimes the comments would be posted and other times they weren't. Very odd.

    The current posting at the head of my page is the only one that has appeared without the facility even to write a comment into a box, and I can't work out how to change its settings.

  4. @peewiglet: Changing the Discussion Setting affects all posts published after the change, not already published ones. To override the setting for a single post, you deactivate the Allow Comments and Allow Pings options in the Discussion module of the post editor, or in Quick Edit (Posts>Edit > hover under post title).

Topic Closed

This topic has been closed to new replies.

About this Topic