Need help? Check out our Support site, then


How to get Rid of File Name of Photos on Blog

  1. Hi,
    On my blog if you hover over the photos within the posts the file name appears. For example, for April 29 it is DSC_0013. When I click on the photo and it opens the blog post for April 29 and then click on the photo, only the title shows "Can It Happen?" I would prefer to always have the title show and not "DSC_0013." This occurs for all of my photos.

    As directed, I entered "Can It Happen?" into the "title" field and also in the "alternate text" field.

    The following link appears in the Link URL box:: http://nancywolitzer.files.wordpress.com/2012/04/dsc_00133.jpg
    Could this be why the file name "DSC_0013" is showing? If so, what do I enter in the LINK URL box. I believe it was self-populated.

    Thank you for your help.

    The blog I need help with is nancywolitzer.com.

  2. Do you need the link? If not, have you tried deleting the link altogether? That might solve it. If not, the only other thing I can think of is renaming the file from DSC_0013 to Can It Happen and then uploading again.

  3. To get your photos not to show the camera's file name, you just need to name your files differently before uploading them from your computer.

    As for the rest:

    http://en.support.wordpress.com/images/image-settings/

  4. thesacredpath
    Staff

    Actually what is happening is that wordpress automatically pulls the file name and inserts it into the "title" field when you insert an image. You need to edit that title, and you also should put in an "alt" title as well. If you leave either one of these out, search engines will not index your images, and it also creates an XHTML error on your site for each image that does not have them.

  5. Thank you everyone for your replies.

    I have deleted the photo currently in my post, renamed the file on my computer to "Can It Happen.jpg", and then uploaded it to the post. The file name now matches the title. Both the title and alt title fields were edited to have the title I want ("Can It Happen?"). I published these changes but "DSC_0013" is still showing on my photo on the blog. I am positive that I published the changes because I altered the caption and the revised caption is showing.

    I'm not sure what to do now. Any suggestions?

    Thanks again.

  6. I figured it out! I have to delete all old versions of the photo from my media library.

    Thanks again for everyone's help.

    Nancy

  7. thesacredpath
    Staff

    You didn't have to delete and re-add the photo. All you had to do was open the post, edit the existing image and change the title and then add the "alt" title as well.

  8. I tried that initially and it did not work. Also, as I say above deleting and readding the photo didn't work either until all other versions were deleted from my media library

  9. I meant to end with a thank you in my previous comment and just noticed that I neglected to do so. So thank you for all of your help with this. I don't quite understand myself why what you suggested did not do the trick.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.