Need help? Check out our Support site, then


How to not have all posts on Home page?

  1. I'm using Twenty Ten and each new post just pushes the last one down the Home page. I only have a few posts so far but I would like Home to have only my latest post. The titles of all of them also show up in the right sidebar. Is it possible to have only my latest post on Home page? And, if yes, then how?

    Thank you. My blog is http://www.emusingthings.com

    Deanna

    The blog I need help with is emusingthings.com.

  2. Infinite scrolling is an interface technique that allows users to browse through content without clicking on pagination links. Instead, all users have to do is scroll to the bottom of the page and new content will automatically load on the current page.

    Staff have introduced "infinite scroll" to Twenty Ten and that means you no longer have control over how many pages display on the front page of your blog, unless you disable infinite scrolling using a workaround.

  3. oops! I made an error "pages display" was meant to be "posts display".

  4. Thanks! I'll have a look at the workaround link you put there.

  5. The workaround is easy and works well. You're welcome. :)

  6. Hi,

    I went to the "disable infinite scrolling using a workaround" link above and I'm confused! I don't know if I have a widgets footer...I have "share" down there...is that what it is? There were too many options and I don't quite know the lingo to know what I have in place so as to pick the right 'fix'.

    Would you be able to cut and paste the specific thing I should do?

    Thanks in advance!

  7. ....I tried one of the suggestions just to try something.... it seems to be working, though I still see a button that says "load more posts" . Can I get rid of that?

    Thanks.

  8. See here please > http://onecoolsitebloggingtips.com/2012/03/16/disabling-infinite-scroll-on-your-wordpress-com-blog/

    If you have a theme with footer widgets like Bueno all you need to do is install an empty text widget into any footer area for widgets here > Appearance > Widgets.

    1. Open the text widget, add nothing just click "save" and "close" inside the widget.
    2. Then go to > Settings > Reading
      set the number of post you want to display on the front page
      Blog pages show at most __posts
    3. Scroll down there will be an option displayed to disable infinite scroll.
      To infinity and beyond __Scroll Infinitely
      Remove the checkmark scroll down and click "save changes"

    The number of posts set on that same Reading page to display on the front page will now prevail.

  9. Edit: like Bueno, Twenty Ten, Twenty Eleven, etc. ie. any theme that has footer widgets.

  10. Hi Timethief,

    Thanks for your response! That's the thing I did...put an empty text widget there.

    I was very confused by the instructions....I've just re-read them to figure out why and a couple things confused me:

    In particular, for neebies who are visual and well...new...like me....can you put the instruction like this:

    1. Install the "text" widget into any footer area
    2. Open the text widget, add nothing just click "save" and "close" inside the widget. (though it opened automatically).
    3. etc....

    It may seem extra simple but reading instructions isn't everyone's strong point. I think I'm sorted out now at least. phew!

    Thanks!
    :-)

  11. I'm glad you have sorted this now. Best wishes for trouble free blogging.

  12. Thanks for this idea. I just changed my blog to show one posting on the home page. I will see how that goes and if my readers enjoy it better than having all posts on the home page.

  13. I have just changed mine too as all of my posts were on my home page but now the 'leave a comment box' has disappeared? does anyone know what i can do? I am going to change it back to all the posts on one page for now until i can figure this out?

Topic Closed

This topic has been closed to new replies.

About this Topic