Need help? Check out our Support site, then


How to remove a Home page

  1. Hi,

    I am working on the above site and for some reason there is a HOME page that I did not add. I went to my DASHBOARD, then PAGES and tried to delete it however it is not listed on there.

    There is no edit button at the bottom of the page to even add content if I wanted to.

    What can I do about this?

    Thanks so much for your help and have a nice day! :)

    The blog I need help with is therainbowwontwait.wordpress.com.

  2. Home page = blog front = landing page = main blog URL. The idea of removing the blog front doesn't make sense. You don't remove or edit the blog front, you tell it what to display: either your latest posts or an intro page. If you want it to display an intro page you have created, you do this in Settings > Reading.

  3. First off, I am not tech savvy at all so all I know is when I go to my Pages there is no Home Page yet it is there on the Menu and no place to add or edit.

    Thanks! :)

  4. This is the Home page http://lisavproulx.wordpress.com/

  5. By default the front page of your blog displays all published posts (not pages) in reverse chronological order, with the most recently published post on top.

    However, if you do not want all the posts to show on the front page, then you can create a static front page called for example “Welcome” for your site and a “Blog” page for posts. To do that create two pages first http://en.support.wordpress.com/pages/

    After you do that you go to > Settings > Reading and make the designation change and click “save changes”.
    http://en.support.wordpress.com/pages/front-page/

    A static page (select below)
    Front page:
    Posts page:

  6. Thanks, it's just there is a HOME on my menu and when it is clicked it says page not found. I can't delete it, edit it or or add content to it.

    It can stay but I can't put anything in it.

  7. Thanks for the link but that's not the site I am talking about. I added the link above...Thanks for your time! :)

  8. a) You can't find "Home" in Pages > All Pages because it's not a link to such a page, it's a built-in link to the blog front.
    b) By default, the blog front displays your latest posts. At the moment it shows the Not-Found message because you deleted the sample "Hello World" post. It will be back to normal once you publish your first post (Posts > Add New).
    c) If you aren't going to publish any posts, you need to set the blog front to display a static page instead. As timethief and I already said, you do this in Settings > Reading.

  9. Gotcha! Now that made sense! :) I added a new post and all is well with the site.

    Thanks again to everyone for their help. Sorry to be a pest, I just don't know much about this kind of stuff.

    Have a great day! :)

Topic Closed

This topic has been closed to new replies.

About this Topic