Need help? Check out our Support site, then


How to Remove Comments Box from Static Front Page

  1. The only entry I found with this sort of question had answers that aren't working for me:

    How do I remove the header and comments from a static front page?

    http://en.forums.wordpress.com/topic/how-do-i-remove-the-header-and-comments-from-a-static-front-page?replies=2#post-777101

    New to wordpress and appreciate any help and how-to's to get that box off of my static front page.

    Thank you!

    The blog I need help with is readmyblips.wordpress.com.

  2. Open the page you set as your static front page in the editor, go to the screen options tab at upper right and make sure the "discussion" module is activated. Then go down below the text area, click on the right end of the discussion module title bar to open it and deselect "allow comments" and "allow trackbacks" and then update the page.

  3. Thanks so much for your help. I never would have noticed that options tab.

    However, I do not have "allow comments" and "allow trackbacks" boxes in that discussion module bar. The comments box I did have was already unticked.

    http://readmyblips.files.wordpress.com/2011/12/options.jpg

    Any idea why I don't have the boxes and what else I should/could do?

    Again, thanks very much!

  4. Sorry, I should have coffee before posting. There are no such boxes below the text area either. Only a box for 'sharing buttons.'

    Thanks for your patience :)

  5. Your approach is wrong. Please got to the Screen Options settings include Discussion. After you have enabled that setting again then to enable or disable comments on any individual post or page the instructions are found here > http://en.support.wordpress.com/enable-disable-comments/

  6. Ah, thank you so much! Box is gone now and this is resolved.

    Appreciate your kind help muchly!

  7. You're welcome and best wishes for happy blogging. :)

Topic Closed

This topic has been closed to new replies.

About this Topic