Need help? Check out our Support site, then


How to remove recent posts from additional pages?

  1. I added a few pages to my blog that are supposed to be static (ex. an About Me page). But now that I have made my first blog post, it shows up both on the main page (where it should) but also at the bottom of every page I added to the blog (beneath my static content). How do I remove my recent posts from the bottom of my blog's additional pages (I only want them to show on the main page)? For example, on my Patterns Used page (http://tiesthatbindquilting.wordpress.com/patterns-used/), I only want to see the photo of the pattern and the link to where it is from but not have my blog post at the bottom. Thank you for your help!

    Kim

    The blog I need help with is tiesthatbindquilting.wordpress.com.

  2. Hello there,
    Widgets now have "visibility" settings so we can select which pages they display on. See here: http://en.support.wordpress.com/widgets/#widget-visibility

  3. I took a closer look at your blog and there's something going on that I'm puzzling over. I'm going to click out of this thread and leave it to another volunteer to help you. I do suggest that you read this article on the Twenty Eleven theme and how it is designed. I think if you read it you will be able to resolve your issue.

  4. Thanks - I looked at the Widgets visibility but I don't think that's where my problem is because it isn't an issue with the sidebar content. The posts simply show up at the bottom of every page.

    I'll dig more into the page on how the theme is designed and see if that helps.

  5. Figured it out! The additional pages had gotten set in the "showcase" format which basically makes them have both static and dynamic content (and I simply wanted static). I changed them to the "default" format and the posts showing at the bottom went away and left simply my static content.

    Thanks for your help!

  6. Hooray! You resolved this. :)

Topic Closed

This topic has been closed to new replies.

About this Topic