Need help? Check out our Support site, then


How To Set Default Attachment Display Settings In WordPress?

  1. This article:

    http://www.adamstruve.com/2013/02/how-to-set-default-attachment-display-settings-in-wordpress/

    describes how to set the default link behaviour for embedded images for self-hosted WordPress.

    How do you do this in WordPress.com blogs?

    It is such a pain having to manually set this preference *every* time you include an image.

    The blog I need help with is geotopoi.wordpress.com.

  2. Unless you've disabled it, the Photo Carousel is the default display for images displayed via the Gallery feature. If you disabled it, then you have your choice of None, Attachment page or Media file.

    For individual images, WordPress.com is supposed to remember the last choice you made in the Media Uploader/Handler. I assume by your comment that this is not working for you?

  3. I'm using Add Media / Insert Media / Media Library and selecting individual images to insert into posts.

    The Attachment Display Settings / Link To option always defaults to 'Media file', even when I have previously selected 'Attachment Page'.

  4. I'm using Chrome 30 and haven't run into this specific problem. Can you tell us what browser and version you are using? Is your flash up to date and javascript enabled?

    Also, do you delete your browser cookies/cache each time you shut down your browser?

  5. Chrome Version 30.0.1599.101 m

    Flash version 11.9.900.117

    Javascript: Allow all sites to run JavaScript (recommended)

    Cookies are not deleted and the cache not cleared on browser exit.

  6. Looking at your sites, the only thing I can think to suggest besides using the Gallery feature (default is the overlay Photo Carousel), which you don't appear to be using, or you could simply select multiple images to insert at once.

    Choose your images (after adding captions, etc.), pick the image size, select "Link to Attachment page" and double check that all your images show the same settings and when you click the "Insert into post" button, they all should be inserted in your post and linked to the Attachment page.

  7. Thanks for your suggestions, Jen.

    I'll probably just live with having to set this option every time.

    The reason I don't insert multiple images at once is that I usually change the order of the images from that in the media library. All that cutting and pasting afterwards would outweigh any saving gained in not having to select from the dropdown for each one.

    Actually, I have just tried a test of this. It appears that with multiple images selected, changing the 'Link To' dropdown setting only applies to the currently highlighted item of the multiple selection. Pretty flaky behaviour, really.

    Oh well...

  8. I've just gone through my Media Handler after previously inserting multiple images with the link to Attachment page selected and on every image I click on, it's still showing Attachment page as the current linkto selection. I don't know why this isn't happening for you, we're both using the same browser and settings, so I'll tag this for a staff assist.

  9. The media uploader should be "remembering" your last choice. I just tested it myself: I uploaded some images, and as I did so I switched from attachment page to media file, and saved that post. Then I created a new post, and when I went to upload images it defaulted to media file automatically.

  10. Hi Jackie. I'm pleased it is working for you, although sadly that doesn't help me any. For me, the setting reverts to Media File on the next insert within the same post after having changed it for the previous item to Attachment Page, never mind remembering it between posts.

    Is there no way of setting image_default_link_type and making it stick?

    Is it something to do with the theme (The Journalist v1.9) I'm using?

  11. The setting should update when you save a post. I just tested it in Journalist 1.9 and it still works.

    Just so I'm clear: you create a new post, and add media. From there you upload images, change them to attachment page, and insert them, and save the post. Next time you do the same thing but the setting has defaulted back to media file?

    You are running Windows?

    Can you try a different browser to see if the behavior is the same or works as designed?

  12. Yes.

    Yes, Windows 8 64 bit.

    Steps:

    1. Posts / Add new
    2. Add Media / Select item from Media Library - Link To is 'Media File', so change the dropdown selection to 'Attachment Page' / Insert into post
    3. Repeat 2 with different item from Media Library - Link To has reverted to 'Media File', so change it again.
    4. Save Draft
    5. Repeat steps 1-4 with new post - Link To is always defaulting to 'Media File'

    In addition to Chrome, I get identical behaviour in:

    Opera 17.0.1241.45
    IE 10.0.9200.16721

  13. Hi Jackiedana- we're both using Chrome 30 and where it works for me (remembering the last choice), it isn't working for the OP. Since there are many photos on his site that link to the Media file and not an attachment page, I have to wonder if this may be a problem with selecting an item from a drop down menu as described here. http://en.forums.wordpress.com/topic/difficulty-updating-my-profile

    Off to try it in FireFox.

  14. I'm on Win7Pro

  15. Everything works as expected for me in FF24

    @gastepen, again, you can insert multiple images at the same time, no need to insert one by one. You can make any necessary changes in the Media Handler before inserting them in your post.

    Of course still doesn't solve why your settings seem to keep reverting to "media file". :(

  16. I'm at a loss here since we can't reproduce this issue. @gastephen, have you tried selecting attachment page for the setting when creating a gallery? Does that make any difference?

  17. @justjennifer, thanks, but again, inserting multiple creates more work in re-ordering afterwards.

    @jackiedana, interestingly the option defaults to 'Attachment page' when creating a gallery, but again does not remember its setting if this is changed.

    Just out of interest, are you trying to reproduce this on Win 8?

  18. It looks like this is something specific to your blog. I have reported it to our developers and I'll let you know what I find out.

  19. @jackiedana, thanks very much for your help. will look forward to hearing the outcome of this.

  20. Hello, I would like to join in the thread - I have the same issues as gastephen and I am using a Mac with Safari browser. When adding a group of images to a gallery and selecting attachment page only one of the images is loaded as attachment - so it is less time consuming in the long run to add images one by one.

  21. @foofar
    Are you referring to a free hosted WordPress.com blog? If so what's the URL? There is no blog linked to your username and all I can find is this one http://foofar.wordpress.com/ which is devoid of any blogger created content.

  22. @foofar, the issue is whether "media file" or "attachment page" is selected by default on the media uploader. What you're describing sounds different, and it would be good to post a new thread with your issue, including the WordPress.com blog in question and more details about your issue.

    @gastephen I'm still looking into your issue but it may be next week before I can get back to you on this. I appreciate your patience.

  23. @gastephen your default media setting should now be set to "attachment page". Please give it a try and let me know if you run into any further issues with this.

  24. @jackiedana, fantastic! Thanks very much for getting a resolution to this issue.

    You wouldn't by any chance be able to do the same for my other blog, lustrebox.wordpress.com, would you?

  25. You should be all set on lustrebox.wordpress.com now. :)

  26. @jackiedana, so specific to his blogs or specific to his account?

    Shouldn't the last choice become the default setting?

    What happens if in the future gastephen (for example) would prefer the media file and not the attachment page? Does he need again to contact support to make the change?

    Needless-to-say I'm finding this rather odd (to say the least).

  27. In general this should not be happening, but there was something funky with the settings on his blogs.

    If it continues to be an issue, then yes, it would be appropriate to contact us again.

  28. @jackiedana, marvellous! thanks for setting that on lustrebox too.

    @justjennifer, 'something funky with the settings' being the technical web development term, obviously ;-)

    Seriously, though, I'd be interested in knowing if this issue is a result of user settings or whether it stems from a bug in your system.

  29. I don't think there's anything on your end that caused this since it was a setting in the database that we had to reset manually.

Topic Closed

This topic has been closed to new replies.

About this Topic