Need help? Check out our Support site, then


How to show the RSS feeds of my blog on my homepage

  1. I understand that some of the themes don't have the link for subscription to my blog's RSS feed there. I want it to show on my homepage, either at the bottom or sidebar. Anyway to do this?
    Thanks!

  2. you should be able to show the link to your blog's rss by inserting the meta widget into your sidebar. and even themes which don't support widgets should have the meta widget by default in its setup.

  3. I came here to post the same question that jodypeng did. I signed up for an RSS feed at feedburner.com. I did not have the RSS symbol showing on my page. I applied the instructions in the FAQ area under "Put Your Feed in your Sidebar". I did what they said and then hit the save button under Text Widgets, but nothing happened. How can I get the RSS symbol to show up on my page for people to subscribe?
    http://LifeWithoutLimitsNow.wordpress.com

    Also, in the FAQ it says "Here are some you can link to". I don't quite understand that.

    Isn't a RSS feed symbol on our site there for people to subscribe to our site.

    Thanks,
    Kathy

    [Link fixed - drmike]

  4. kathytalkin: note that your blog url does not have a www in it. all wp.com blog do not have www in their url.

    i've read that faq page. it only says that by doing so it will add a link to your rss feed. it's not for subscribing purposes. as far as i know, feedburner has a code for you to insert in the text widget so that your readers can subscribe to your rss feed. however, i'm not sure if this is applicable with wp.com bloggers as codes like this usually have javascript in it, which is not allowed on wp.com blogs for security reasons.

    besides, people only need the rss feed address so that they can add your rss feed to their rss feed reader. our rss feed url is very simple: username.wordpress.com/feed

  5. @Kathy:
    I see a text widget in your blog sidebar that has links to your feeds. The only thing you need to do is change the feed URLs in the text widget to reflect the Feedburner URLs (they currently point to the wordpress feeds)

    @Jody:
    Follow Sulz's advice and just add in the meta widget to your sidebar

  6. judyb12: thanks for clearing the bit up about feedburner. i don't use it so i'm not aware.

  7. Tha RSS widget is actually for RSS feeds from elsewhere.

    Kathy, the 'lifewithoutlimitsnow' bit takes the place of the 'www' bit. They can't coexist and actually is a broken link for 30% of the net as well as most search engine spiders.

  8. I have the code from feedburner to insert into the Text Widget. I cannot remember (nor find) what tab to click on in order to get to the Text Widget. I am hoping that this will place the RSS symbol on my blogsite.

    What is the Tab I click on to get to the Text Widget?

  9. I just placed a post and see that the time is way off. It is 11:08am here and my last post is around 7 hours ahead of the true time. I set the time up somewhere in my account. It said to put -6 for central time which I did.

    I know this is minor compared to everything I want to learn that is more important, but just thought I would ask since I just now noticed it.

  10. Widgets are at Dashboard -> presentation -> Sidebar widgets

    Your post should appear at the time you set it to as long as you've got the timezone set correctly. It would help us help you if you told us what the post consisted of.

  11. The post I am refering to are the ones I have been posting right here. I can look into the time zone thing another time - it's really not important.

    Back to RSS - I want to get the RSS icon to show up on my page and it won't. Not sure what I am doing incorrectly. I set up an account with Feedburner and pasted the code into the Text Widget area. I clicked on the blue lines of the text widget and pasted in the code that Feedburner gave me. I clicked on the Save button at the bottom of the page.
    Is that correct?

    No RSS icon shows on my page - when I click on the text links on the right side of the page, they do not connect to anything either. I must be missing a step, but I have followed what the written instructions say. Any suggestions?
    Thanks.
    lifewithoutlimitsnow.wordpress.com

  12. can you show us the code you're pasting into the text widget?

  13. If you're talking about the time of your posts in the forum, the forum is set to GMT and changing the time settings on your own blog will not change that in the forum.

  14. Kathytalkin, you say you have feedburner feeds, but as far as I can see, the feeds in your subscribe section are wordpress feeds. Feedburner feeds generally start with feeds.feedburner.com/yournamehere. I have feedburner links on my page if you want to see a reference.

    If you are using feedburner, they give you a bunch of options for what you want your link to look like in the 'optimize your feed' section. The orange rss symbol is included in the first two options. Select that, then copy the code in the box at the bottom of the page and copy that into your widget.

  15. <If you are using feedburner, they give you a bunch of options for what you want your link to look like in the 'optimize your feed' section. The orange rss symbol is included in the first two options. Select that, then copy the code in the box at the bottom of the page and copy that into your widget. >

    That is what I did. This is the code that Feedburner has for me to paste

    <img src="http://www.feedburner.com/fb/images/pub/feed-icon32x32.png" alt="" style="border:0"/><a

    Underneath that section it says "Use as a Widget in" and then it has Type Pad as a choice.
    Do I need to use that? I just pasted this code into the Widget at WordPress.

    I will try it again tomorrow. I think it is time for me to take a break today!
    Thanks for the advice. I will get back to it tomorrow evening.

    Kathy

  16. My previous post did not contain the entire code. Here it is:

    <img src="http://www.feedburner.com/fb/images/pub/feed-icon32x32.png" alt="" style="border:0"/><a

  17. HHmmm.....the code has 3 aditional lines but for some reason it is not copying into these posts. The code that is coming across is the last two lines. There are 3 lines on top of it.

  18. You have to use backticks here in the forums. that's the key over the tab key and to the left of the '1' key on a standard pc keyboard.

  19. This is what it should look like:
    <a href="http://feeds.feedburner.com/wordpress/XXXXXXXXXX" title="Subscribe to my feed" rel="alternate" type="application/rss+xml"><img src="http://www.feedburner.com/fb/images/pub/feed-icon32x32.png" alt="" style="border:0"/></a><a href="http://feeds.feedburner.com/wordpress/XXXXXXXXXX" title="Subscribe to my feed" rel="alternate" type="application/rss+xml">Subscribe in a reader</a>
    with the "XXXXXXXXXX"s replaced with the correct title of your feed. It sounds like you're doing it correctly, but your changes aren't saving. Please try it again. I really don't understand how you were able to make that "Subscribe" text widget but are having trouble now.

  20. Thanks Judy. :)

  21. you're welcome; i hope it helped with the problem :)

  22. Hello I am very new to wordpress and don't understand the jargon at all? Please will someone explain very simply how I go about setting up an RSS link so that people can subscribe to my blog. I am using the Ambiru theme which is very minimalistic and doesn't have widgets etc (atleast not that I know of)

  23. When you're starting out, it's a good idea to check the FAQ first, because the basic issues have all been covered in there. Here's what I found searching the FAQ for RSS:

    http://faq.wordpress.com/?s=RSS

  24. phoenix pcd writes:"If you are using feedburner, they give you a bunch of options for what you want your link to look like in the 'optimize your feed' section. The orange rss symbol is included in the first two options. Select that, then copy the code in the box at the bottom of the page and copy that into your widget."

    I, too, am having trouble setting up my blog as an RSS link in my side-bar.

    I now have feedburner, but when I get to the "optimize your feed" section, I do not see any options, per se. On the left side-bar there is: "VIEW" and "SOURCES", none of which I could find any options. Are they on the right-hand side, which includes "SmartFeed" and "SmartCast"?

    I am on a Mac system and it seems that WordPress is mostly geared to PC, because there are WP "plugins" and so forth that I can't figure out how to install.

    Can one of you very patient people help me with this? I am sorry to be so dense! I've been spending hours trying to figure this out. It is all so confusing.

    Sincerely,
    Cameron
    http://cameron5408.wordpress.com

Topic Closed

This topic has been closed to new replies.

About this Topic