Need help? Check out our Support site, then


how to stop hypens in widgets in twenty eleven theme

  1. How do I turn off the hyphenation of words in text widgets in the twenty eleven theme.
    The hyphens don't show when using Internet Explorer but they do on Firefox.
    Is there is simple way of turning hyphenation off completely?
    An idiots guide on how to do this would be appreciated.
    Hope that you can help.
    Thank you.

    The blog I need help with is cornishsoul.wordpress.com.

  2. Hello there,
    You can't "turn them off". You can switch to using a theme that displays widget content the way you want. Or you can purchase a custom design upgrade and do the required CSS editing to change the appearance. See here for details on purchasing the annually renewable custom and CSS editing:
    Custom design - Frequently Asked Questions
    http://en.support.wordpress.com/custom-design/#frequently-asked-questions
    http://en.support.wordpress.com/custom-design/
    http://en.support.wordpress.com/custom-design/editing-css/
    http://en.support.wordpress.com/custom-design/custom-fonts/

  3. Hello timethief
    Thank you for replying to my query.
    I did suspect that this might be the case.
    Thanks for the information about the custom design upgrade.

  4. Are you talking about your "About Me" widget?

    Looking at your site it in IE8 (sorry, no later version of ie on the computer I am on right now), all the text looks good. However in FF27, lines are broken mid-word with hypens.

    I've tagged this for Staff input.

  5. Hello justjennifer

    Yes I am talking about my "About Me" widget.

    That is also what I found, on IE it looked OK but on FF the lines are broken.

    If you find a way to resolve this it would be most appreciated.

    Thanks

  6. I'm sorry I did not understand what you meant. This thread was tagged for Staff by justjennifer. Please subscribe to it please so you are notified when they respond.

  7. Thank you. Will do.

  8. jerrysarcastic
    Staff

    Hi @cornishsoul

    I was not able to see the same issue in FF (on a Mac) but in checking your widget settings, I noticed that the text you entered was separated into 3 sections (paragraphs) but you did not have this option checked: https://cloudup.com/cpjODVrmfs1

    Does changing the "Automatically add paragraphs" setting clear things up for you?

  9. Hi
    Sorry, no I tried checking "Automatically add paragraphs" but the hyphens are still there when viewed on FF. I am viewing on a PC.
    I don't suppose you have any other ideas?
    Thanks.

  10. jerrysarcastic
    Staff

    I have tested on my end (Windows 7/Firefox 27) and cannot duplicate the issue on my end, which is the OS/browser combo I see you using on my end.

    Can you go here and verify? Just copy your user agent string in here:

    http://thismachine.info/

    Also, have you had this problem with when viewing your site using a different browser (Chrome, for example) or even a different computer?

    Thanks for the additional info!

  11. Screenshots:

    ff27 win7pro hyphenated words appear at end of some lines.

    chrome33 win7pro no hyphenated words

  12. jerrysarcastic
    Staff

    @justjennifer - Thanks, it helped to see that. :)

    @cornishsoul - Is that the issue you are referring to? Recent builds of Firefox resepct the CSS 3 hyphenation property to break up long words where there is not space for them in a given website element.

    To disable this, You can try the following line of code.

    #secondary { -moz-hyphens: none; }

    You will need the Custom Design upgrade (which you can purchase in the store tab of your site's Admin Dashboard) which will apply this code to all widgets on the site, or you can use the following HTML in your widget:

    <div style="-moz-hyphens:none;">
    <p>I am a Cornish soul and wanted to create this blog as a focus for my own spiritual journey. I take inspiration from teachers of various traditions, from nature, friends, books and life.  But mostly I try to follow my own heart. </p> 
    
    <p>I’ve been on this spiritual quest for many years but feel like I am just starting out.  </p>
    
    <p>I do have some insights and inspirations along the way though and would like to share them with you.  And I am hoping that you can empathise with my often failed attempts to be a better person and more enlightened being.  <a href="http://cornishsoul.wordpress.com/about/">More about me.</a></p>
    </div>

    Note: If you use the HTML code above, you will not need the "insert paragraphs automatically" option any more, as the paragraph tags are in the code now. Also, the HTML code option affects this widget only. You will still get hyphens in other text widgets if you don't add HTML to each one, or use the Custom CSS option, which is applied site-wide.

    Hope that helps. Please let me know if you have any further questions.

  13. Thank you so much, inserting this HTML into this text widget has worked. :-)

  14. jerrysarcastic
    Staff

    Great, glad I could help!

    Happy Blogging :)

Topic Closed

This topic has been closed to new replies.

About this Topic