Need help? Check out our Support site, then


Hyperlinks in the Web-based WordPress

  1. Hello, I am using the Web-based WordPress on a Macintosh, OS X version 10.3.9 with the Safari browser. I cannot figure out how to make hyperlinks in my posts active. Using the standard HTML tag format with "a href=site..." doesn't work (although other HTML coding, such as bold, italics, and lists does work). Any help with this would be appreciated.

  2. Which editor are you using and can we see an example?

  3. Steps: I launch the Safari browser, log in at the WordPress site, and choose Dashboard > Write. There is no toolbar on the Write screen.

    I just noticed that the toolbar is displayed on a Windows 2000 machine with IE version 6. This toolbar, which includes a links button, does not display on my home configuration (Macintosh, OS X version 10.3.9 with the Safari browser, as mentioned above)Perhaps it's the browser?

  4. I do have exactly the same problem. (Same Safari 10.3.9 Mac OSX)
    There is no editor, even when I reload the particular site like recomanded.

    I would really appreciate, if someone could help us out,.... :)

    Cheers

  5. Please make sure you have javascript turned on and Flash installed. I still need to know which editor you are using. You may want to try using the non-rich text editor. You can change this at Dashboard -> Users -> Your Profile -> at the bottom of the page.

  6. Thanks Mike, javaskript is on, flash installed.

    I have had already the same idea, switched off the non-rich editor and from then on I could use quicktags, when I type them in manually. It just costs much time, but this is even better as not to be able to create links,...

    Where can I find out which editor I "use" to help you?

    Cheers Hanna

  7. Please reread my post. I mention where the settings for the editor is. :)

  8. Dr. Mike: I was using the visual rich editor with Javascript on and Flash installed. The manually created links work with "Use the visual rich editor when writing" turned off.

    Shift+reload with the visual rich editor turned on did not display the Editor toolbar with the "auto links" button and spell checker. As instructed in the support forum, I had the browser open on the Write Post screen and pressed shift+reload to reload the full page.

    According to the installed plug-in list for my Safari browser, these are present:
    Java 1.3.1 Plug-in (CFM)
    Java 1.4.2_09 Plug-in (Cocoa)
    Shockwave Flash 8.0 r22

  9. I think the answer is that the Editor toolbar is not compatible with Safari, regardless of whether the visual rich editor is on or off. I tested the Mac browsers I have:

    With the visual rich editor on...
    . Mozilla 1.7.8 does display the Editor toolbar with link tool
    . Firefox 1.5.0.1 also displays it
    . Microsoft Internet Explorer 5.2.3 does not have the toolbar, but it has other issues that would prevent me from using it.

    So I'll use Mozilla or Firefox to post, until there is a fix for the Safari browser.

  10. Thanks qctester for sharing your experience.
    Thats bad news for me though :( . I dont have or use Mozilla or Firefox.
    I wonder, if I should? I prefer it simple generally with not to many browser at my computer,...
    Cheers

  11. since you're on Mac you might want to use MarsEdit, ecto [<strike>or even wonderful BBedit</strike>]

  12. I understand not wanting too many browsers on your Mac -- memory, memory, memory!
    But one nice solution might be Mozilla's new Mac-specific browser (sort of a sister to Firefox) called Camino. You can find it at http://www.caminobrowser.org/. Hope this helps!

  13. I'm a little confused. So, the hyperlinks aren't compatible with Safari? Is that the deal?

    FR

  14. No, Safari doesn't support WYSIWYG fully. That's probably why you're having issues with the Rich Editor as TinyMCE (that the offical name of the text editor) doesn't fully work with Safari.

  15. Ok, that clears that up. Thank you!

    New questions related to the same: when I get onto another computer with internet explorer, for instance, is there any trick I must use to create the hyperlink? Or do I simply copy/paste the link into my post and it automatically turns into a hyperlink?

    Also, can one of you tell me how to turn a word into a link in a post? For instance, if I want to say "I went to Google the other day and..." how do I turn "Google" into a hotlink that, when clicked on, will take me to http://www.google.com without having to put the actual http address into the post?

    Thanks!

    FR

Topic Closed

This topic has been closed to new replies.

About this Topic