Need help? Check out our Support site, then


I am not able to password protect some pages in my blog.

  1. I have tried to add passwordprotection to my pages in the control panel, but when i navigate to the page and enter the password i get redirected to the front page the first time, consecutive times i just get the "enter password" form.

    I have tried both when i am logged into wordpress, and logged out. I have also deleted all cookies.

    Can anybody tell me what i am doing wrong?

    The blog I need help with is pex2.wordpress.com.

  2. Please post the url for the wordpress.COM blog you are referring to so we can begin to help you.

  3. Of course.

    pex2.wordpress.com

    Thank you for the promt reply.

  4. I'm sorry but I have no help to offer. I did a forum search and found this recent thread http://en.forums.wordpress.com/topic/password-protect-certain-posts?replies=2#post-403344 and this one http://en.forums.wordpress.com/topic/password-protected-page-does-not-work-for-ie8?replies=5 I do not know if either specifically address your problem. If they don't you will have to wait for another volunteer to help or for Staff to do so.

  5. Ok, thank you!
    I can't find any answers in these threads, so I'm still waiting for someone to help me solve the problem.

  6. I still have problems with password-protection of single pages. It does'nt work with Microsoft Internet Explorer 7 (IE7), but works very well with Firefox!

    But I have to have it work with IE7, because most of my readers use this browser.

    Does anybody have an answer?

  7. In IE7, log out of wordpress, clear the browser cache and cookies, restart the browser and then look again without signing into wordpress. IE is known to hang onto cookies and cache files even after clearing them, and sometimes you have to do it a couple times.

    Also, can you give us a link to an actual page where this is happening?

  8. Thanks;
    I have tried to clear the cash and cookies several times, but still it doesn't work with IE7 (norwegian version)!

    The pages is here: http://pex2.wordpress.com/
    The problem occurs when I try to open the page named "Kontakter for styret", and this page has the password "pex2"

  9. Interesting issue...

    In Firefox, after visiting the page with the password, after clearing the cookies and refreshing the page (without closing and reopening the browser) I am prompted for the password. As it should be.

    In IE8 not. Here I have to close and reopen the browser after clearing the cookies. I tried clearing the cookies 5 times, but nothing worked. I had to close the browser first.

  10. OK, but what have I done wrong in wordpress dashboard?

    And why isn't this a problem for other users of wordpress, using password protection?

  11. YOu haven't done anything wrong; it's your browser and your browser settings. And it probably IS a problem for other people using the same software combination as you.

  12. Now I also have upgraded to IE8 Norwegian, but still have the same problems!

  13. As raincoaster has said, it is a browser issue, not a wordpress.com issue. There is really not much that can be done.

Topic Closed

This topic has been closed to new replies.

About this Topic